Cache misses daily

cache

#1

On a daily basis I consistently get cache misses on some assets but then not on others. My site is https://ridestoke.com

Please see here for the misses: https://tools.pingdom.com/#5a540801c3000000

I have worked with the webhost support and they have confirmed that nothing should be coming from the origin server telling cloudflare not to cache. Any ideas?

Thanks


#2

I inspected a few random image, CSS and JS resource files and all show a reasonably long cache-control header and nothing that would obviously be blocking caching.

The first time I loaded the page everything I inspected was a cache miss, but after loading a couple more times (with my browser cache disabled) I am seeing cache hits on nearly all items.

I suspect that everything is working fine, but perhaps you just don’t have enough traffic for the resources to be in the cache at the particular node that the diagnostic tool happens to hit? I ran the test again and many of your resources are now reporting a hit: https://tools.pingdom.com/#5a541a2dcb800000

The slowest part of the site (for me) is the Instagram images, followed by Google Fonts.


#3

Thanks. How long does cloudflare cache the files? I see this happen on a daily basis which is why I’m asking.


#4

A maximum based on your cache-control headers, but Cloudflare doesn’t guarantee a minimum time to cache, rather items are cached or evicted as needed.


#5

@thedaveCA is correct. In some instances we will actually cache the value longer than the TTL, sometimes less (if infrequently accessed). The other thing to note is that unless you are using Argo tiered caching these values are per PoP. So if you infrequently have visitors from Greece their cache may expire more frequently than your LHR visitors (as an example).


#6

Is there a way to increase the cache hit rate or have cloudflare cache the assets longer with without dumping them?

I thought about the cache everything rule but this is a wordpress site and I don’t want to expose private pages that are cached.


#7

You can’t force an increased cache rate. You can only force some things to be cached.

I find that the sites with the highest cache HIT rates are the ones that are really busy.

  1. So many hits from all over keep that cache refreshed.
  2. With so many hits being cached, all those uncached hits become a very small percentage.

#8

Thanks. Is it possible to create a cache everything rule for say the entire wordpress wp-content folder or just the wp-content/uploads folder but not have it expose private pages from wordpress?

I’ve seen some threads here where they talk about using caution but I did not see discussion on just those wordpress folders.


#9

Setting “cache everything” would not help these folders, as their content is already set to be cached by default. It would change nothing. You can check which file types Cloudflare caches by default here:


#10

Cache Everything is very complicated when it comes to WordPress, it will trip you up in unexpected ways.

(It also won’t help at all in this case: If your static resources aren’t requested enough to be cached at a particular node, the WordPress pages won’t be either).


closed #11

This topic was automatically closed after 14 days. New replies are no longer allowed.