Cache issue with Cloudflare?

Hi community!

Hope you can help with this! Recently migrated from Dreamhost shared hosting to GreenGeeks shared with a better plan. Anyhow, site migration went well, and we re-integrated cloudflare with A record and new IP. I am using the Ezoic ad network so they changed details on their side with IP information.

Oddly, I posted a new article on my site and while it APPEARS when I am logged into my own Wordpress admin, when I do icognito, any other browser (for Mac) including my own iPhone browsers, the new article DO NOT appear on home page. I cleared cache on every browser, in Cloudflare, on Wordpress, and yes, the post was published with current date.

I purged ALL cache under Cloudflare and problem is not solved. Your help and IDEAS appreciated!

Does the article appear if you go to its direct URL using incognito?

What’s the URL of the home page?

Hi there:

I does not appear in incognito either. Any way to share the url without sharing it widely? :smiley: If that is not an option let me know. Thank you for responding so quickly.

Ezoic has their own HTML caching. Did you enable this feature?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.