Cache Issue - Most recent blog posts not showing to everyone


Hey CloudFlarers!

Hope you are all well :slight_smile: I would really appreciate your help with this issue!

I use CloudFlare and also the Cloudways Breeze plugin on our website

The issue is that we have blog posts which we update each week, where the url stays the same each week (e.g.this blog post we update every Monday and Friday with new selections). However, some visitors do not see this updated content and instead see the old content when they visit the url.

So it sounds like our website has a caching issue.

The blog is:

When I spoke to Cloudways support, they said that the caching is being done by CloudFlare:

This sounds correct, as on the very rare occasion the website is down, the most recent cached version of the site is shown by CloudFlare. My current CloudFlare cache settings are:

Do you have any suggestions over changes I could make to any settings or any tests I should run, to help identify the problem and correct it?

Many thanks if you could help!


Do you have a Cache Everything rule under Page Rules?


Hey @DimitrisT thanks for your reply!

I do not have any Page Rules set up:

“You do not have any Page Rules yet. Click ‘Create Page Rule’ above to get started.”

Hope that helps and any questions please let me know :slight_smile:

Thanks again!


Without a “Cache Everything” Page Rule, Cloudflare only caches specific file extensions:

That leaves browser caching:

Either your web site or Cloudflare has set browser caching too high. You could configure your .htaccess to have high browser caching for static files such as images, and low caching for HTML.


Great thanks @DimitrisT very helpful I’ll look into these articles, thanks again!