Cache Everything Redirecting Desktop Traffic to AMP Pages

A month or so ago I setup cache everything page rules on my website (motorverso.com). However, since doing so maybe once a week or some or all of the pages on my site included desktop traffic will get redirected to my AMP pages (/amp).

I can correct this by clearly the Cloudflare cache but over time it comes back again.

For AMP I am using the AMPforWP plugin.

Is there an additional page rule I should be using to stop this happening?

Thanks,

Paul.

That would suggest your server sends at some point such a redirect which then gets cached by Cloudflare (possibly also just a JavaScript redirect).

Either you disable Cache Everything or your remove that redirect.

Is there a way to stop Cloudflare caching 301 redirects?

You’d need a page rule for that, but that would apply to regular responses as well. A 301 typically is a rather definitive statement and will also get cached by browsers. You best don’t send one if you are not sure.

This topic was automatically closed after 30 days. New replies are no longer allowed.