Cache everything Page Rules for Wordpress dont work

If I add a whole site “cache everything” page rule after 4 or 5 other basic page rules to my wordpress site it causes anyone who tries to login to be logged right out. What could be causing this how can it be fixed?

Without knowing those 4 or 5 other Page Rules, I’d say the problem is because you’re trying to Cache Everything on a site that uses cookies.

Thank you I tried to follow the information I could find and here are the other rules I am using and if your correct is there a way to cache everything except the cookies? Okay I see the “Bypass Cache on Cookie” is an enterprise level configuration. Very slick the best way to increase speed costs the most Very Well if you find any other way Please feel free to let me know otherwise Good Job! Thank you ttyl

|1|http://internettop40.com/

Always Use HTTPS|On

|2|https://www.internettop40.com/wp-login.php?*

Cache Level: Bypass|On

|3|internettop40.com/wp-admin

Security Level: High, Cache Level: Bypass, Disable Apps, Disable Performance|On

|4|*internettop40.com/preview=true

Cache Level: Bypass|On

|5|internettop40.com/wp-content/

Browser Cache TTL: an hour, Edge Cache TTL: 2 hours|On

Try modifying the Match for wp-login to end with wp-login.php* I’m not even sure putting a wildcard in for query strings works. It looks like you’ve disabled the page rules, so I can’t test to be sure.

I’ve had success with an easier approach using this plugin:

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.