Cache Everything Page Rule with CloudFlare Workers

I’m using a Worker to proxy to

The worker is working correctly, is properly loading the contents of like I want. But it’s using a decent amount of requests and I’m trying to decrease that.

So, I created a Page Rule for and enabled Cache Everything and set the Edge Cache TTL to 24 hours.

However, when visiting it’s still showing the content as being Dynamic instead of showing HIT or MISS.

Can you not use Cache Everything when using a worker on a subdomain?

Workers are never cached unless you cache the content inside the worker.