Cache Everything Page Rule Not Working

I see a ton of posts on here about using Page Rules to do a Cache Everything but I’m not sure why mine is not working this time around. I’ve used the feature (Cache Everything on a specific URL to deal with big waves of traffic) but it’s just not happening when I try it now.

Based on previous posts, I have:

  1. Adjusted the Browser Cache TTL to Respect Existing Headers
  2. Provided the Cache-Control header with a value of “public” (also tried not providing one at all)
  3. Created a Page Rule with Cache Everything a 2 month Edge Cache TTL

This is the page I’ve been testing: West Virginia State Parks - Digital Relativity : Digital Relativity

And my page rule is matching these: https://digitalrelativity.com/portfolio/*

I’m getting a cf-cache-status of DYNAMIC every time I hit the page, regardless of browser, incognito, etc.

Is there something basic that I’m missing?

Do you have a screenshot of your Page Rule?

Definitely!

I did misspeak about the TTL though. It’s a 1 month Edge TTL, not 2.

Screenshot below

Try removing the https:// from the URL (required) on the Page Rule - I’m not sure if the schema (i.e https://) makes it’s way into that field, so Cloudflare might not match on it.

Use digitalrelativity.com/portfolio/*

Edit: looks like it should be fine as the scheme is included - as per https://support.cloudflare.com/hc/en-us/articles/218411427-Understanding-and-configuring-Cloudflare-Page-Rules-Page-Rules-Tutorial-

Thanks!

I just updated that Page Rule as a test, on the off chance that it is some bug with scheme matching. Same result though :confused:

Do you know where these headers are coming from?

x-cacheable: SHORT
x-cache: HIT: 5
x-cache-group: normal

As a guess, if WP Engine uses Cloudflare (for SaaS) themselves then their Cloudflare configuration ‘overrules’ your own since it goes to them.

2 Likes

In this instance, I’ve actually disabled the WP engine page cache, so those headers should be gone now. I can confirm that the page definitely feels slower.

I’m also not using the WP Engine CNAME/proxy tools, just A records with the IP, so it shouldn’t be using any of the WP Engine Cloudflare infrastructure.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.