Cache Everything Makes Comment and Search Box not Clickable


#1

I need some help, After enabling “cache everything” I noticed my blog comment form and search form are not clickable.


#2

Can you post the URL?


#3

The comment form and search box aren’t functioning.


#4

Try disabling Rocket Loader under “Speed”.


#5

still not working.


#6

I guess i will try to use another comment form. Will try facebook.

Thanks for your assistance.


#7

Are you sure you disabled it? It is still loaded.


#9

Yea, i temporarily disabled it, then made sure it was disabled by checking the html source code (view-source:https://… for the rocket loader scripts) then checked multiple pages and still the problem was there.

I later re-enabled it, Now im trying to embed another comment form


#10

Thats not a Cloudflare issue, its a JavaScript related. Apparently your aec312a131707c5b21cf824d33820087.js script blocks something on the page.


#11

But It works perfectly when i disable Cache everything.


#12

Can you disable it and purge your cache?


#13

Okay. Will do that now.


#14

Cache everything disabled, Cache Purged and forms are working perfectly


#15

I am afraid not for me.


#16

Yes, u may be right. I might have tested it too early. I noticed wen the page loads completely the error still persists.

I guess it not cloudflare then.


#17

Let me disable rocket loader and see.


#18

Thanks. Minify Javascript from CF and WP Rocket + Rocket Loader were the issue

I guess my template has issues with Javascripts minification

Its working now. I will go ahead and enable caching everything now.


#19

Try using the Autoptimize plugin for minification if you are using Wordpress.


#20

Okay.


#21

No problem, just make sure to turn off all minification from Cloudflare or any other source and let Autoptimize do it all.