Cache Control: no-cache, private

Hello,

We have purchased Subscription specially for Support. But enable to contact support or drop support ticket.

please help us.

On my main domain I applied cache level standard but nothing is cache. And I applied cache level everything on my stagging server. Its working on stagging server but it occurred many error like login redirect to 419 error.

What is I missing, please help us.

Main Domain: https://templatelelo.com
Stagging Sub Domain: https://stagging.templatelelo.com

Thanks

On your main domain, images, CSS, etc are successfully being cached.

A “cache everything” rule is likely to cause errors because your site uses login, and also has a “Vary” header that says the HTML will be different based on User-Agent. You can’t cache HTML under those conditions, which is why your server is sending the no-cache header. If you force it with a “cache everything” rule, the site will not work correctly.

Why cache control showing no-cache, private

That’s coming from your server. It’s in your HTML as well. Whatever you used to build the site is setting that, because caching the page will cause errors.

Many modern sites can’t have the HTML cached. But your site correctly has images and support files cached.

How to resolve the cache control private issue from my server, can you suggest some points?

Your site’s HTML cannot be cached and still have the site working properly. That’s why the header is being set. The only way to change this would be to make a new site using a different platform.