Cache always interfere with live update

i have a small issue, ever since i use cloudflare, my back end updates do not automatically appear on my front website until i go and purge my cache. please how can i get automatic update without going back to clear cache before i get live update appear on front end.

Hi @user1271,

Do you have any ‘cache everything’ page rules configured in Cloudflare?

If not, Cloudflare should only cache static resources on your site.

yes i have rule ; cache level, cache everything.

That is why… You are telling Cloudflare to cache your entire site, and therefore it is not updating when you make changes. You will either need to disable that rule, change the edge cache TTL so any updates show quicker, or use the WordPress plugin or API to purge the cache when you update something.

This topic was automatically closed after 31 days. New replies are no longer allowed.