BYPASS when rule says cache everything

I’d like to cache small speedtest files on my site, I have a page rule that caches everything when a user access that subdomain:

However, this rule is not working. Everything on (except for the favicon) is being bypassed.

Why is this happening? How can I fix this?

Update, I’ve noticed favicons are the only item being cached. What rule can I set to cache PHP and everything else?

Check your origin cache control headers - BYPASS indicates your are instructing caches not to store or cache the responses:

Got it all set, thank you!

1 Like

I would recommend fixing this at your origin, but if you don’t want to do that you can disable origin cache control on your page rule and set an edge cache TTL also. That will force us to cache but I’d really recommend you look at why your origin is issuing no-cache instructions.

1 Like

Thanks @simon, finally, how could I ignore cache content independent of the query string? For example, index.php?home=true gets cached along with index.php. Is this possible?

You can’t do “ignore query string” in combination with “cache everything” on the page rule.

However you could try setting a custom cache key using a cache rule:

Thanks, I’ve tried messing around with that like so:

This is just saying that garbage.php and garbage.php?something=false will both go to the same item, right? If so, that’s brilliant.

Yes “Ignore Query String” is the setting you’re looking for.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.