Bypass Page Rule Not Working

Having trouble with this page: WATCH - Peoples Church

I’ve set page rule to bypass the cache on this page and another page (the only 2 page rules of my allotted 3 for the free account). I was still having caching issues and reached out to my hosting and after
running a CURL it is still being cached from Cloudflare (and is not being cached from Siteground)

❯ curl -IX GET WATCH - Peoples Church
cf-cache-status: HIT
x-proxy-cache: MISS

Any thoughts on how to resolve this?

That URL should not be cached in the first place, so it would seem as if you have a page rule which explicitly caches it. It’s probably best to remove that instead.

Possibly your page rule order is not correct either. Your rule needs to be first. Post a screenshot of your page rules.

1 Like

You appear to be on a partner setup via your host and would need to make changes at your host’s.

Generally, I’d recommend to disable that on you host’s side and configure it directly on your Cloudflare account, assuming you signed up with your own account.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.