"By-pass" PageRules does not work as expected

I have setup following page rules for my site, but the “ByPass” page rules for this URL "Wishlist - Artsy Bucket ™ doesn’t work as expected. It always get cached by Cloudflare or some other proxies. I have purged everything multiple times. Please help me.

That page rule looks correct, and Cloudflare header shows that page (just the HTML part) as DYNAMIC.

What is you see that’s not updating?

1 Like

Hi, we added a dynamic timestamp on that /wishlist page, and when you refresh it, it should always show the latest clock in UTC. But if you goes to that URL “Wishlist - Artsy Bucket ™” you will see an old clock time that doesn’t change. Can you please try that ?

May you want to tell us how exactly you implemented that dynamic timestamp?

Like @sdayman already wrote: the site Wishlist - Artsy Bucket ™ is responding with a header:
image

cf-cache-status: DYNAMIC

Therefore CloudFlare has not cached it and just proxies what your origin Server responses with. So I assume your server cached it somewhere at his end, but its not cached by CloudFlare.

1 Like

We have Redis object cache enabled, and no page cache on our server. This wishlist page always get cached somethere.

We just add a PHP line to print out current date & time on server. That’s all.

I’m seeing this in the header:
< x-runcloud-srcache-fetch: HIT

Have you tried disabling RunCache?

Or at least Purge the entire Runcloud Cache? (Clear All Cache)

Maybe try to add that page as an exclusion:

3 Likes

Thank you so much, adding this URL to exclude path of RunCache solved my problem.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.