Bulk Redirect Not Working on HTTPS

I have set up bulk redirects from

dresscode . danhakimi . com → https:// thesecondbutton . com
https:// dresscode . danhakimi . com → https:// thesecondbutton . com

I have an a record subdomain for dresscode pointing to… I’ve tried about twelve different IP addresses, but the redirect setup page tells me it can point to literally any IP address because the redirect goes through first:

I get an error message. For the lazy:

You’ve requested a page on a website that is part of the Cloudflare network. The host (dresscode . danhakimi . com) resolved to an IP address that the owner of the website does not have access to.

(spaces addesd because I apparently can’t include links here)

Why is it resolving to any address at all? What’s going on?

It seems I can’t edit this, but to clarify – the redirect works with http, but not https.

That’s interesting, because dresscode isn’t even proxied. Cloudflare features won’t even kick in unless the record is proxied.

As an aside, you don’t even need the scheme when creating a bulk redirect rule match. No scheme will match either http or https.

1 Like

I turned proxying on and off multiple times, to see if that would make any difference at all. It didn’t. I turned it back on now, and it still isn’t helping.

I added the scheme because it wasn’t working without the scheme. It still isn’t.

It still is working with http.

For what it’s worth, the error page isn’t showing up now, the connection is just timing out.

Aaaand now it’s working… not sure what change did it, but I imagine whatever it was, it probably took a few minutes, which is also probaby why my frequent changes didn’t work before…

For what it’s worth, I never wanted anything to be proxied, and still don’t, but namesilo doesn’t do https redirects at all, so… whatever.

Well… it looks like it’s working, but Google Search Console still doesn’t see any 301 redirect happening at all…

And on my end, some of the redirects are working, and some aren’t. if I go to [old url]/shirts, I get redirected (as intended) to [new url]/shirts, but if I go to [old url]/pusocbd, it redirects to [new url], which is not what I intended. I have the last two boxes ticked, which… should work, right?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.