Bulk redirect issue from newby

I’ve added a rule in a Bulk Redirect list and created and deployed a rule. However, on testing it’s not working.

I even tried a single redirect, and /membership still doesn’t redirect:

I can’t figure out what I’m doing wrong… can someone point me in the right direction? I’m just trying to set up a page redirect from /membership to /ceo-program (I know ceo-program is a 404 but that’s as I wanted to test the rule first).

Given that you are directing the www to Kajabi, many of their settings are likely overruling what you’re trying to do, while you’re also using their platform.

As such, you might need to decide between either Kajabi, OR the redirect rules.

As it happens, I have two Kajabi sites, and the other is working fine. The DNS is set up identically… here’s an example where one page rule works and the other doesn’t:

I can’t for the life of me figure out why one domain works and the other doesn’t.

Kajabi recommended switching the www to DNS only for 48 hours to let the domain resolve on this website, (DNS Checker - DNS Check Propagation Tool), and then switching it back to proxy. I’m giving this a try—they seem to think it’ll work.

If you’ve added a rule in a Bulk Redirect list on Cloudflare and deployed it, but it’s not working when you test it, there could be several reasons why this is happening. Here are some troubleshooting steps you can take:

  1. Check for any conflicts: Ensure there are no conflicting rules in your Cloudflare Firewall or Page Rules that could be affecting the redirects. Conflicting rules could cause the redirects to not work as expected.
  2. Verify the URL patterns: Double-check the source and target URL patterns in the redirect rule to ensure they’re accurate and match the expected format. Make sure that any regular expressions or wildcard patterns are correctly formatted.
  3. Check the rule order: Make sure the redirect rule is listed before any other matching rules. Cloudflare applies rules in order from the top down, so if there is a conflicting rule earlier in the list, it might be preventing your new rule from working.
  4. Clear cache: Clear your browser cache and any server-side caches that may be interfering with the redirects.
  5. Test with a different browser: Test the redirects with a different browser to rule out any browser-specific issues.
  6. Verify the DNS settings: Ensure that your DNS settings are configured correctly, and that your domain is correctly pointing to your Cloudflare account.

Ok… it gets weirder. Here is the bulk list with one entry:

http://foundercoach.com[/]membership → https://www[.]foundercoach.com/ceo-program

I’m close… but I can’t understand why it’s not working!

Here’s the DNS:

I’ve re-proxied the www CNAME to see if that works… it hasn’t yet.

It still doesn’t work!!!