Bulk KV write example doesn't write metadata

I have been developing an application that is going to write in bulk to a particular KV namespace. I have the application already writing one entry with metadata and it is working, but I can’t get the /bulk api endpoint to write metadata. I just tried the example in the tutorial, and it doesn’t work either:

curl -X PUT “https://api.cloudflare.com/client/v4/accounts/01a7362d577a6c3019a474fd6f485823/storage/kv/namespaces/0f2ac74b498b48028cb68387c421e279/bulk
-H “X-Auth-Email: [email protected]
-H “X-Auth-Key: c2547eb745079dac9320b638f5e225cf483cc5cfdda41”
-H “Content-Type: application/json”
–data ‘[{“key”:“My-Key”,“value”:“Some string”,“expiration”:1578435000,“expiration_ttl”:300,“metadata”:{“someMetadataKey”:“someMetadataValue”},“base64”:false}]’

Is the curl given by CloudFlare, if I run this curl (with the correct data substituted of course) it writes the key and value but not the metadata. Does this functionality work for anyone?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.