Buld System V2 does not build my project

With V1 working and deployed succesfully. With V2 errors.

Logs:


|2023-11-06T15:20:46.992536Z|Cloning repository...|
|---|---|
|2023-11-06T15:20:48.383264Z|From https://github.com/bla bla|
|2023-11-06T15:20:48.383977Z| * branch            361b0e38067cd6b6914a75848d6c012b757d083d -> FETCH_HEAD|
|2023-11-06T15:20:48.384174Z||
|2023-11-06T15:20:48.625632Z|HEAD is now at 361b0e3 fix for service worker|
|2023-11-06T15:20:48.626339Z||
|2023-11-06T15:20:48.736698Z||
|2023-11-06T15:20:48.77001Z|Success: Finished cloning repository files|
|2023-11-06T15:20:50.111977Z|Detected the following tools from environment: [email protected], [email protected], [email protected]|
|2023-11-06T15:20:50.112851Z|Installing project dependencies: yarn|
|2023-11-06T15:20:50.855432Z|➀ YN0070: Migrating from Yarn 1; automatically enabling the compatibility node-modules linker πŸ‘|
|2023-11-06T15:20:50.855783Z||
|2023-11-06T15:20:50.988555Z|➀ YN0000: β”Œ Resolution step|
|2023-11-06T15:20:51.700761Z|➀ YN0061: β”‚ babel-eslint@npm:10.1.0 is deprecated: babel-eslint is now @babel/eslint-parser. This package will no longer receive updates.|
|2023-11-06T15:20:53.655034Z|➀ YN0061: β”‚ rollup-plugin-terser@npm:7.0.2 is deprecated: This package has been deprecated and is no longer maintained. Please use @rollup/plugin-terser|
|2023-11-06T15:20:54.325936Z|➀ YN0061: β”‚ @babel/plugin-proposal-private-methods@npm:7.18.6 is deprecated: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-private-methods instead.|
|2023-11-06T15:20:54.338Z|➀ YN0061: β”‚ @babel/plugin-proposal-nullish-coalescing-operator@npm:7.18.6 is deprecated: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-nullish-coalescing-operator instead.|
|2023-11-06T15:20:54.34651Z|➀ YN0061: β”‚ @babel/plugin-proposal-class-properties@npm:7.18.6 is deprecated: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-class-properties instead.|
|2023-11-06T15:20:54.350842Z|➀ YN0061: β”‚ @babel/plugin-proposal-private-property-in-object@npm:7.21.11 is deprecated: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-private-property-in-object instead.|
|2023-11-06T15:20:54.366224Z|➀ YN0061: β”‚ @babel/plugin-proposal-optional-chaining@npm:7.21.0 is deprecated: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-optional-chaining instead.|
|2023-11-06T15:20:54.410134Z|➀ YN0061: β”‚ @babel/plugin-proposal-numeric-separator@npm:7.18.6 is deprecated: This proposal has been merged to the ECMAScript standard and thus this plugin is no longer maintained. Please use @babel/plugin-transform-numeric-separator instead.|
|2023-11-06T15:20:55.733118Z|➀ YN0032: β”‚ canvas@npm:2.11.2: Implicit dependencies on node-gyp are discouraged|
|2023-11-06T15:20:56.96921Z|➀ YN0061: β”‚ sourcemap-codec@npm:1.4.8 is deprecated: Please use @jridgewell/sourcemap-codec instead|
|2023-11-06T15:20:57.0594Z|➀ YN0032: β”‚ nan@npm:2.18.0: Implicit dependencies on node-gyp are discouraged|
|2023-11-06T15:20:57.827786Z|➀ YN0061: β”‚ expression-eval@npm:2.1.0 is deprecated: The expression-eval npm package is no longer maintained. The package was originally published as part of a now-completed personal project, and I do not have incentives to continue maintenance.|
|2023-11-06T15:20:58.657936Z|➀ YN0032: β”‚ fsevents@npm:2.3.3: Implicit dependencies on node-gyp are discouraged|
|2023-11-06T15:20:58.926394Z|➀ YN0061: β”‚ tilebelt@npm:1.0.1 is deprecated: This module is now under the @mapbox namespace: install @mapbox/tilebelt instead|
|2023-11-06T15:21:09.810658Z|➀ YN0002: β”‚ @amg/btech@workspace:. doesn't provide @babel/plugin-syntax-flow (pe8d6c), requested by eslint-plugin-flowtype|
|2023-11-06T15:21:09.811214Z|➀ YN0002: β”‚ @amg/btech@workspace:. doesn't provide @babel/plugin-transform-react-jsx (pdb980), requested by eslint-plugin-flowtype|
|2023-11-06T15:21:09.811463Z|➀ YN0002: β”‚ @amg/btech@workspace:. doesn't provide @mui/system (peb00f), requested by @mui/x-data-grid|
|2023-11-06T15:21:09.811618Z|➀ YN0002: β”‚ @amg/btech@workspace:. doesn't provide @mui/system (p52a9b), requested by @mui/x-date-pickers|
|2023-11-06T15:21:09.811788Z|➀ YN0002: β”‚ @amg/btech@workspace:. doesn't provide @types/react (pfa154), requested by react-markdown|
|2023-11-06T15:21:09.811923Z|➀ YN0060: β”‚ @amg/btech@workspace:. provides react (pd478a) with version 18.2.0, which doesn't satisfy what react-qr-barcode-scanner and some of its descendants request|
|2023-11-06T15:21:09.812057Z|➀ YN0060: β”‚ @amg/btech@workspace:. provides react-dom (p53ea9) with version 18.2.0, which doesn't satisfy what react-qr-barcode-scanner and some of its descendants request|
|2023-11-06T15:21:09.812289Z|➀ YN0002: β”‚ @amg/btech@workspace:. doesn't provide webpack (p8afce), requested by worker-loader|
|2023-11-06T15:21:09.812445Z|➀ YN0002: β”‚ @deck.gl/geo-layers@npm:8.9.32 [994a9] doesn't provide @loaders.gl/gltf (pf4614), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.812584Z|➀ YN0002: β”‚ @deck.gl/geo-layers@npm:8.9.32 [994a9] doesn't provide @loaders.gl/images (pb2279), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.812738Z|➀ YN0002: β”‚ @deck.gl/geo-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/engine (pacc95), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.81288Z|➀ YN0002: β”‚ @deck.gl/geo-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/gltools (p5c22b), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.81301Z|➀ YN0002: β”‚ @deck.gl/geo-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/shadertools (p19b0b), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.813147Z|➀ YN0002: β”‚ @deck.gl/geo-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/webgl (p97b65), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.813285Z|➀ YN0002: β”‚ @deck.gl/mesh-layers@npm:8.9.32 [994a9] doesn't provide @loaders.gl/images (p10df7), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.81345Z|➀ YN0002: β”‚ @deck.gl/mesh-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/engine (p4b295), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.813598Z|➀ YN0002: β”‚ @deck.gl/mesh-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/gltools (p44358), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.813749Z|➀ YN0002: β”‚ @deck.gl/mesh-layers@npm:8.9.32 [994a9] doesn't provide @luma.gl/webgl (pa3ae9), requested by @luma.gl/experimental|
|2023-11-06T15:21:09.814018Z|➀ YN0002: β”‚ @react-pdf-viewer/attachment@npm:3.12.0 [34edc] doesn't provide pdfjs-dist (p05b9e), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.814337Z|➀ YN0002: β”‚ @react-pdf-viewer/bookmark@npm:3.12.0 [34edc] doesn't provide pdfjs-dist (p89a04), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.816002Z|➀ YN0002: β”‚ @react-pdf-viewer/default-layout@npm:3.12.0 [62047] doesn't provide pdfjs-dist (p3c9be), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.816231Z|➀ YN0002: β”‚ @react-pdf-viewer/full-screen@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (p89661), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.816391Z|➀ YN0002: β”‚ @react-pdf-viewer/get-file@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (pc4e6f), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.816531Z|➀ YN0002: β”‚ @react-pdf-viewer/open@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (p2f0d1), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.816668Z|➀ YN0002: β”‚ @react-pdf-viewer/page-navigation@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (pf799a), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.818915Z|➀ YN0002: β”‚ @react-pdf-viewer/print@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (p45eb3), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.819226Z|➀ YN0002: β”‚ @react-pdf-viewer/properties@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (p859c3), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.819402Z|➀ YN0002: β”‚ @react-pdf-viewer/rotate@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (p7f7c7), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.819542Z|➀ YN0002: β”‚ @react-pdf-viewer/scroll-mode@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (pd620d), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.819671Z|➀ YN0002: β”‚ @react-pdf-viewer/search@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (pb4236), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.81982Z|➀ YN0002: β”‚ @react-pdf-viewer/selection-mode@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (paa72b), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.81995Z|➀ YN0002: β”‚ @react-pdf-viewer/theme@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (p40238), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.820076Z|➀ YN0002: β”‚ @react-pdf-viewer/thumbnail@npm:3.12.0 [34edc] doesn't provide pdfjs-dist (pd6f1f), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.820201Z|➀ YN0002: β”‚ @react-pdf-viewer/toolbar@npm:3.12.0 [34edc] doesn't provide pdfjs-dist (p58f04), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.820348Z|➀ YN0002: β”‚ @react-pdf-viewer/zoom@npm:3.12.0 [e7dd7] doesn't provide pdfjs-dist (pc97f8), requested by @react-pdf-viewer/core|
|2023-11-06T15:21:09.820481Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @loaders.gl/core (p07779), requested by @deck.gl/carto|
|2023-11-06T15:21:09.820606Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @loaders.gl/core (pd7a43), requested by @deck.gl/geo-layers|
|2023-11-06T15:21:09.820938Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @loaders.gl/core (pd28c7), requested by @deck.gl/layers|
|2023-11-06T15:21:09.821104Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/constants (p892f6), requested by @deck.gl/extensions|
|2023-11-06T15:21:09.821376Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/constants (pc587e), requested by @deck.gl/google-maps|
|2023-11-06T15:21:09.821514Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/core (pdbedb), requested by @deck.gl/aggregation-layers|
|2023-11-06T15:21:09.821639Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/core (p271b1), requested by @deck.gl/extensions|
|2023-11-06T15:21:09.821803Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/core (p1ba8c), requested by @deck.gl/geo-layers|
|2023-11-06T15:21:09.821955Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/core (p42927), requested by @deck.gl/google-maps|
|2023-11-06T15:21:09.822084Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/core (p3e2c4), requested by @deck.gl/layers|
|2023-11-06T15:21:09.822208Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @luma.gl/core (pe7fea), requested by @deck.gl/mesh-layers|
|2023-11-06T15:21:09.822346Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @math.gl/core (p565f4), requested by @deck.gl/extensions|
|2023-11-06T15:21:09.822473Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @math.gl/core (p17299), requested by @deck.gl/google-maps|
|2023-11-06T15:21:09.822609Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @math.gl/web-mercator (pbcb3c), requested by @deck.gl/extensions|
|2023-11-06T15:21:09.822746Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide @types/react (pe8f71), requested by @deck.gl/react|
|2023-11-06T15:21:09.822875Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide gl-matrix (pa1a21), requested by @deck.gl/extensions|
|2023-11-06T15:21:09.822999Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide react (p4230a), requested by @deck.gl/react|
|2023-11-06T15:21:09.823122Z|➀ YN0002: β”‚ deck.gl@npm:8.9.32 doesn't provide react-dom (pdd760), requested by @deck.gl/react|
|2023-11-06T15:21:09.823253Z|➀ YN0002: β”‚ eslint-config-react-app@npm:7.0.1 [62047] doesn't provide @babel/plugin-syntax-flow (paba2c), requested by eslint-plugin-flowtype|
|2023-11-06T15:21:09.82339Z|➀ YN0002: β”‚ eslint-config-react-app@npm:7.0.1 [62047] doesn't provide @babel/plugin-transform-react-jsx (pb5980), requested by eslint-plugin-flowtype|
|2023-11-06T15:21:09.82352Z|➀ YN0002: β”‚ notistack@npm:3.0.1 [62047] doesn't provide csstype (pf8acb), requested by goober|
|2023-11-06T15:21:09.823661Z|➀ YN0000: β”‚ Some peer dependencies are incorrectly met; run yarn explain peer-requirements <hash> for details, where <hash> is the six-letter p-prefixed code|
|2023-11-06T15:21:09.8238Z|➀ YN0000: β”” Completed in 18s 831ms|
|2023-11-06T15:21:09.904379Z|➀ YN0000: β”Œ Post-resolution validation|
|2023-11-06T15:21:09.904847Z|➀ YN0028: β”‚ The lockfile would have been modified by this install, which is explicitly forbidden.|
|2023-11-06T15:21:09.905385Z|➀ YN0000: β”” Completed|
|2023-11-06T15:21:09.9057Z|➀ YN0000: Failed with errors in 18s 918ms|
|2023-11-06T15:21:10.069387Z|Error: Exit with error code: 1|
|2023-11-06T15:21:10.069731Z|    at ChildProcess.<anonymous> (/snapshot/dist/run-build.js)|
|2023-11-06T15:21:10.069905Z|    at Object.onceWrapper (node:events:652:26)|
|2023-11-06T15:21:10.070041Z|    at ChildProcess.emit (node:events:537:28)|
|2023-11-06T15:21:10.07017Z|    at ChildProcess._handle.onexit (node:internal/child_process:291:12)|
|2023-11-06T15:21:10.077367Z|Failed: build command exited with code: 1|
|2023-11-06T15:21:12.495662Z|Failed: error occurred while running build command|

You should add the env var YARN_VERSION with the value 1. The v2 uses Yarn v3 which changes the Yarn lock file and causes problems.

1 Like

That worked. It’s also faster. Took 1.15Min less :slight_smile:
thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.