Builds stuck with Got “Failed: an internal error occurred.”

Hi, I all my Pages builds started to fail yesterday after 10-20 seconds with the following error:

10:11:07.116	Cloning repository...
10:11:08.146	From https://github.com/Salet/autobus-do-popeyes
10:11:08.146	 * branch            dd09e21441b5c0f59a587f593d8fe68ba30fe7c4 -> FETCH_HEAD
10:11:08.146	
10:11:08.180	HEAD is now at dd09e21 feat: sentry
10:11:08.180	
10:11:08.264	
10:11:08.264	Using v2 root directory strategy
10:11:08.289	Success: Finished cloning repository files
10:11:09.853	
10:11:09.936	✘ [ERROR] No Pages config file found
10:11:09.936	
10:11:09.936	
10:11:09.940	🪵  Logs were written to "/root/.config/.wrangler/logs/wrangler-2024-04-14_08-11-09_674.log"
10:11:09.950	No wrangler.toml file found
10:11:12.805	Failed: an internal error occurred. If this continues, contact support: https://cfl.re/3WgEyrH

Reverting to previous commits doesn’t seem to fix this. I assumed this was due to missing Pages config file, but all the working build logs show this as well. The domain is autobus-do-popeyes.pages.dev, and some example ids of builds that are failing are 31ddf944-be93-4ead-b036-aa66727bfeb6 and 211090d0-bf0a-4fa9-9078-dc0d1177b0b3

Did the previous commits that your reverted to work before this started happening?

Did you make any changes to the build configuration in the intervening time per Build configuration · Cloudflare Pages docs ?

@lcrowter Yes, the previous commits worked without any problems. The only change that I did in the meantime is I added a new env variable, but I did that couple times before without issues

Can you try reverting the change to your environmental variables and see if that resolves the issue?

It… seems to have worked. Is there a limit to the number of variables I can have ? I currently have 8, and the 9th is what caused the issue. It’s named “PUBLIC_FP_API_TOKEN” so there shouldn’t be any clash with what CF uses.

Great. Let me check on that and get back to you as to a possible cause.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.