Builderall / Cloudflare connect

Hi, I struggle to connect my Builderall website with Cloudflare. I’ve contacted support people at Builderall, watched videos, joined a Facebook support group, and searched for solutions in the Community, but I am unable to solve this. This is what I did:

  1. Bought a domain from GoDaddy.
  2. Set up my website on Builderall
  3. Put Builderall’s Nameservers in GoDaddy
  4. After it promulgated and everything worked fine, I went to Cloudflare and added my website.
  5. Cloudflare pulled the info through. At that time it only had 2 x CNAME records (www & * - see picture below)
  6. Cloudflare gave me new Nameservers, which I’ve entered into Godaddy
  7. After I received confirmation from Cloadflare that the Nameservers was updated, I tried to access my site.
  8. The site returned an error, which said that I had to add an A record.
  9. I’ve added the A record with the IP that corresponds with am1.eb4.com (CNAME)
  10. When I then tried to access my site, I received a 404 error: The page you’re trying to visit does not exist
  11. I thought that it was because I did not have an MX record at the time. I then added the MX record, but I still get the same 404 error.

This is my DNS at the moment:


Help would greatly be appreciated!

Hi,

If “am1.eb4us.com” is your hosting account main domain, then remove the A record that you have before it.

else,

double check the A record ip address is the correct one. Disabled the CF proxied option and see if you are able to access it.

Br,
Rui

Good day

Thank you for the feedback. I’ve tried your advice (one suggestion at a time). At the moment my DNS looks like this:

but it gives me this error:

I really don’t know what to do anymore. Maybe I should disconnect my website from my domain and try reconnecting it. I don’t know if that will may any difference?

Any suggestions?

Apart from giving me the IP addresses, it seems like the people at Builderall also don’t know what to do.

Kind regards

Amanda

Hi,

And the IP address match the one that was in A record?

You need either a CNAME to your hosting main domain or an A record to the IP so the domain is resolved.
Add the A record again and in proxy status let it DNS only to see if you are able to reach the site with CF disabled

Hi, I had same issue.
I resolved set up A records with (mydomainame dot com; 65.111.191.293) and CNAME record (www; am1.eb4us.com). My website is reachable now.

my issue now:
I set up mail in Builderall ([email protected] dot com) but it doesn’t work. I test to send an email to, but it doesn’t work (Recipient address rejected: undeliverable address). The server is not configured correctly.
How can I do it?

thanks

Hi, just some feedback for future reference should anyone else have this problem.

I went back to Builderall to check the A record’s IP address.

They gave me a new IP address and everything is working fine now.

Here are my final settings. Thanks a lot for your help:

Have you tried to setup an professional mail with Builderall?

Cloudflare doesn’t proxy emails, to use the mail option proxy status must be DNS only like in the screenshot above.

Yes, my professional email is working - see CNAME webmail settings below.

The TXT and MX settings are for Mailingboss which you also have to set up.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.