Build failed: different built log between today and yesterday on a same commit

I have a strange issue with my Cloudflare Pages.
Today, deployments were exiting with an error.
The commits that were deployed successfully. yesterday.
But today is no longer works.

There are both yesterday and today deployment logs by same commit.

Yesterday

20:29:35.817	Cloning repository...
20:29:37.365	From https://github.com/XXX/XXXXX
20:29:37.366	 * branch            xxxxxxxxxxxxxxxxxxxxx-> FETCH_HEAD
20:29:37.366	
20:29:37.460	HEAD is now at xxxxx Merge pull request #38 from XXXXX/fix-table-name
20:29:37.460	
20:29:37.554	
20:29:37.583	Success: Finished cloning repository files
20:29:38.485	Detected the following tools from environment: [email protected], [email protected]
20:29:38.849	Preparing [email protected] for immediate activation...
20:29:39.500	Installing project dependencies: yarn
20:29:40.307	➤ YN0000: ┌ Resolution step

Today

23:58:20.435	Cloning repository...
23:58:21.928	From https://github.com/XXX/XXXXX
23:58:21.928	 * branch            xxxxxxxxxxxxxxxxxxxxx-> FETCH_HEAD
23:58:21.928	
23:58:22.023	HEAD is now at xxxxx Merge pull request #38 from elda27/fix-table-name
23:58:22.023	
23:58:22.122	
23:58:22.123	Using v2 root directory strategy
23:58:22.157	Success: Finished cloning repository files
23:58:24.329	Detected the following tools from environment: [email protected], python@[email protected]
23:58:24.329	, [email protected], [email protected]
23:58:24.730	Preparing [email protected] for immediate activation...
23:58:25.807	Installing python [email protected]
23:58:25.807	
23:58:25.974	python-build [email protected] /opt/buildhome/.asdf/installs/python/[email protected]
23:58:26.003	python-build: definition not found: [email protected]
23:58:26.011	Error: Exit with error code: 1
23:58:26.011	    at ChildProcess.<anonymous> (/snapshot/dist/run-build.js)
23:58:26.011	    at Object.onceWrapper (node:events:652:26)
23:58:26.012	    at ChildProcess.emit (node:events:537:28)
23:58:26.012	    at ChildProcess._handle.onexit (node:internal/child_process:291:12)
23:58:26.019	Failed: build command exited with code: 1
23:58:26.926	Failed: error occurred while running build command

It causes my project directory that is a pretty complex described below.

  • Root directory contains pyproject.toml to build documentation.
  • First sub directory contains pyproject.toml to build Python script to make contents a part of pages.
  • Second sub directory is a root directory for deployment. Its directory contains package.json and some scripts written by next.js.

Thank you in advance for your help!

1 Like

Not to hijack this thread but I believe we are seeing an issue that is being caused by the same update; Notably, any configuration that is dependent on the directory structure is failing and has only started failing since “Using v2 root directory strategy” started appearing in the logs.

Looks like something has been rolled out silently and the docs no longer align. Interested to hear what the output is. Checking the CHANGELOG there have been no new updates since September last year for pages.

Thanks for your information.
I have no confidence a silent change because I’m newbie of Cloudflare.
Do I need to send feedback to Cloudflare from support page?