Bug Report: Cloudflare Warp disables linux services like ping, ssh client, etc

When you will install warp then when you will set it to always enable and then if you will reboot or shutdown your pc then when you turn it on warp is connected right? but after that you cant ping any host like if you will type ping cloudflare.com it will show you ping sendmsg operation not permitted and it even blocks access to ssh client so you won’t be able to connect to ssh client when you have warp turned on.

And things doesn’t just fixed by turning off warp in order to fix issues you have to first turn off warp and then you have to reboot then only your ping and ssh and all other services like traceroute and much more (as I only know this things for learning linux).

I hope cloudflare team will fix this issue and I am sorry I know my explanation is not so proper if you are having problem in understanding then do let me know I will try my best to explain.

May I ask which WARP connection, protocol, mode if so?

  • 1.1.1.1
  • 1.1.1.1 + WARP
  • WARP+
  • some other

TCP, UDP?
DoH, DoT, Warp?

The tunnels currently only support TCP traffic. This means DNS and ICMP won’t work.

The similar, ping does not work for an example when using Outline “VPN” using ShadowSocks.

Some services also couldn’t work as well like game servers/gaming, or streaming maybe, if so.

Reminds me a bit on this topic:

I think it is not a bug actually, as it seems it is more due to the technological approach.
Could be I am wrong about it here.

1 Like

This one with full families mode enabled.

Yes IDK but there is some thing called icmp which results in not working of ping and ssh client connections.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.