Bug: Page Rule URL encoding broken

If you create a Page Rule that does a 302 redirect to something with &eth in the name then save (either as draft or deploy the page rule will get rewritten to ð. If you try to navigate to the page (such that you are redirected) you are in fact redirected to a url with ð in it rather than &eth in it.

For example, a page rule to redirect to http://foo.bar.com/?bar&ethanol will redirect to http://foo.bar.com/?barðanol. Other characters after the ampersand don’t seem to matter.

That only seems to be a UI issue in the control panel, the redirect itself is done properly.

The redirect was not done properly for me. It redirected me to http://foo.bar.com/?barðanol instead of http://foo.bar.com/?bar&ethanol.

Can you post a screenshot of the rules list and of the dialog when you edit the rule?

I just tried it and it was displayed incorrectly, but the redirect was okay.

Hmm, I just tested again and this time it did go through. I do know that originally I tested and was getting the ð in the browser. I’m uncertain what changed (I fiddled with a bunch to try to fix it, so maybe I accidentally fixed it).

This topic was automatically closed after 14 days. New replies are no longer allowed.