BUG:? New Tunnels including local ports - wont load

I have used tunnels before and have several working.
I recently as of 4/20 made a new tunnel as I always have.

the tunnel was mature and established and I was simply creating a new config.

the localhost is http://localhost:8888 and works
The confg tunnel entry is https://testing.mydomainname.xxx

However the entry is actually being configured as https://testing.mydomainname.xxx:8888

this is not right as some how the tunnel has recently added to te backend the local port to the configuration on the public side and the requests to https:// → testing.mydomainname.xxx are being sent to https:// → testing.mydomainname.xxx:8888 and timing out for obvious reasons.

this IMO seams to be a bug as the UI to config this has not changed and I have done as I always have.

To try to trouble shoot this I nuked the tunnel uninstalled the agent on the local workstation.
set everything back up and also used a differend DNS host name
https:// → testing.myNEWdomainname.xxx is still doing the buggy thing and redireting it to the local port https:// → testing.myNEWdomainname.xxx:8888 even after nuking everything, setting it all back up and using another one of my domainnames.

The tunnel service seams to have some new bug / issue.

Can anyone confirm this is a bug or has something changed, and if so how do I fix this?

I kept hammering on and on to resolve this. Nothing worked then I clicked on the “Connector ID” from the lsit of tunnels. This takes you to “Connector diagnostics”

below I enabled the live stream logs, refreshed the public URL and saw it was complaining about some certificate. with error on windows.

I cleared the logs then refreshed the public url then magically it started working. I did nothing except the above.

2 hours spend on this. Glad its fixed. Yes its free. Happy for that. Concerned about reliability of the feature. Till today its been rock solid.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.