[BUG] DNSSEC for all domains of my account is automatically enabled for no reason

I am Ticket is 2318117

DNSSEC for all domains of my account is automatically enabled for no reason, but it cannot be turned off.

what the ■■■■ is this BUG?

photo_2021-12-02_22-21-16

I tried F12 call to find out the reason, only to find the problem, why is it 400 error?

If you check the network tab in dev tools there is a call to https://dash.cloudflare.com/api/v4/zones/<zone id>/dnssec. What does that show for DNSSEC status?

1 Like

@Jake1st hi,

the current status of the following screenshot… But at the beginning, 200 changed to 400, which was really a weird problem, but it was not turned on originally, I don’t know why it turned on automatically?

Is Cloudflare the registar for your domain as well?

1 Like

I remember, I saw a reverse incident of this.
As I have 90% of my domains DNSSEC signed.
And one day as I remember, approx. ~2 weeks ago, I was switching and doing some changes on domains - was going even with “fast clicking”.
Suddenly, I figured out each doman had “Enable DNSSEC” button.
Later on, I checked, and each actually was signed as it should be.
Nevertheless, I haven’t seen the error in my CF dash.
Day after, all normal.
Nowadays, again all normal as it has to be.

Not sure if that was my Web browser issue, but similar has happened to me before and there was some error. Could be related to CF.

Not sure why all are active/enabled in your case, if so, or just some bug showing “enabled” while it’s disabled.

Please, re-check for sure using online tools like:

1 Like

@fritex @Jake1st

Maybe I uploaded a video to show you what happened in general.

Video url

But I have issued a ticket and haven’t responded so far. Obviously, the efficiency is very poor.

May I ask you what is your ticket number? Could you please share the ticket number here with us? - Okay, now I see you already shared it with us and @Jake1st already escalated it.

Maybe, have you tried Login/Logout and clearing browser cache, if it does or doesn’t help?

Thanks for the video!

Would be of help if you could get the output of the Developer console of your Web browser to a .txt file and also a .har file from it and provide both to the CF support on your ticket, if so.

2 Likes

Yeah sorry forgot to post here but I have escalated your ticket.

3 Likes

@Jake1st @fritex

Thank you for your help. According to the test, the results are as follows:

  1. Chrome and Edge clear cookies and any data, the same problem.
  2. The .hair file has been exported, please analyze it with the assistance of CF RD related units and to ticket.

Many Thanks

There hasn’t been any movement so far, can no one help to fix the BUG? :face_vomiting:

Given it is the weekend you are likely going to have to wait till Monday

2 Likes

Hello, @Jake1st @fritex Thank you for your help. It has been temporarily resolved, and you need to ask CF to modify DNSKEY in the future. The problem cannot be eliminated.

The following is what I want to talk about, but I hope you forgive me for being angry.


Because this ticket ( https://support.cloudflare.com/hc/requests/2318117 ) stub has not been answered for too long, I am not satisfied with this ticket stub reply “it is too slow”!!

So last night, I asked Ent Plan’s existing customers for help and inquired about the customer service, only to get a temporary solution.

Now, after I took the Domain Name to the payment plan, only now I got you back and forth, so the customer service processing efficiency is very poor.

[Temporary solution]

It is to change the manual method and issue the API curl command to force it to close, which can temporarily solve the problem, but DNSKEY (dnsviz.net) may not eliminate the problem. I still need to ask CF for assistance in fixing the problem.

I previously posted a video about the operation of the bug ( Cloudflare DNSSEC Bug - YouTube ), have you seen it? This is a fact, because it is a bug in the CF panel and has not been repaired, and the customer is required to issue an API curl command. In order to forcefully close DNSSEC.

What if the customer has many domain names? This request is unreasonable. The point is that CF is obliged to correct this bug, instead of asking the customer to enter API curl to solve it.

If this is the case, if you ask the customer to enter API curl to solve it, you don’t have to spend money to buy an upgrade plan, and you will be asked to help repair it.

1 Like

I understand that you are angry but neither @fritex nor I are Cloudflare employees. We are volunteers on this forum.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.