Bug(dns): Invalid address: You must enter a valid IPv4 address

dns

#1

1. Summary

I can’t add any record for my e-mail. I get an error:

Invalid address: You must enter a valid IPv4 address.

For example, I can’t set SPF record.

2. Data

  • domain — https://kristinita.ru,
  • NS servers — Cloudflare,
  • domain register — prosto.name,
  • Business e-mail — Zoho Mail.

3. Resources

Articles, that I read:

You must add an SPF record on the NS servers to which your domain is delegated.

4. Steps to reproduce

my DNS Records page:

I add new record:

  • Name — @,
  • Content — v=spf1 include:zoho.com ~all.

I press Add record.

5. Expected behavior

Successful add new SPF-record.

6. Actual behavior

Invalid address: You must enter a valid IPv4 address.

Actual

Thanks.


#2

I’ve seen a similar situation for CNAME. The user switched browsers and was able to get it to work.

Which browser (version) and OS (version) are you using?


#3

Thanks, this is bug in settings of my browser (I don’t find, where exactly), it not Cloudflare bug.

If:

  • Chrome Version 64.0.3282.186 (Official Build) (64-bit),

elif:

  • the newly established Firefox 59.0 64-bit portable.

I get success:

Else:

  • Firefox 59.0 (64-bit) (even in Safe mode), that I usually use,

I get bug above.


#4

Unable to reproduce here, but I have filed an issue for our dev team to review. Thanks for the report and glad you have it working now.


#5

This topic was automatically closed after 14 days. New replies are no longer allowed.