Bucket size after migration from S3

Hello everyone. I had cca 800 GB of data on AWS S3 a few months ago. I synced all objects from S3 to R2 with aws cli tool then, but did not switch over to R2 yet. In the meantime my S3 bucket went from 800 GB to 1.2 TB. Yesterday evening I ran migration with Super Slurper to migrate the rest of the data to my R2 bucket. I chose to skip objects that already existed instead of overwriting them. In the morning I found out it migrated all 1.2 TB of data (1.5 million of objects) and skipped only 10 objects. What I don’t understand is why my Cloudflare bucket is now displaying size 2.1 TB (previous 800 GB + 1.2 TB). It seems that all of 1.2 TB data was transferred again from S3 to R2 on top of my already existing 800 GB. But I cannot find 800 GB of old data in the R2 objects browser. I cannot find files with Modified date older than yesterday evening and I couldn’t find duplicated files when looking in the folders that were 100 % synced a few months ago.

I also tried to check bucket size with aws cli and got this:

aws s3api list-objects --bucket editorialcdn --endpoint-url aaaaaaaaaaaa-removed-this --query ‘[sum(Contents.Size), length(Contents)]’ --output json
[
2085351870021,
3743729
]
So this should be around 2 TB of data and 3.7 millions of objects.

Did I screw something up?