Browser still saying not secure in red letters


#1

I could use some help…I got my site finished but it’s saying NOT SECURE in the address column because I do not have an SSL cerificate, IDK what i’m doing wrong so…here I am.


#2

As a bronze adonis, I can tell you your SSL cert is in place. The issue appears to be one of mixed content.

This is an oft referenced link for mixed content issues: https://developer.mozilla.org/en-US/docs/Web/Security/Mixed_content/How_to_fix_website_with_mixed_content

If you view your page source (using Chrome’s developer tools) I think this file is being called as http which is the source of this error: beach-1236581_1920.jpg . On your contact us page, it seems to not be an issue, sop not sure where that is coming from, but that is the likely culprit. Too bad, as a white pasty geek I could probably use your services if it wasn’t a 1700 mile drive for each session. :smiley:


#3

I got it taken care of, just now!! Thanks though!!


#4

Well, i clicked the link to set up google analytics

Set up google analytics

and now I got the insecure message again


#5

This happen when you allowed both http and https content on your website. In such case, some of your content will get load using https and some of your content will load using http. So the browser will give you warning for insecure content using http.

Based on cscharff answer, it seem that there is a image on your contact page which is getting load on http. Change this on https and your problem will get resolved.

You can follow the below steps to load your image on https

  1. On Cyrpto Page, turn on always use HTTPS.
  2. If you are using cloudflare on WordPress then you need to change the setting there also. Follow the step given in this tutorial to make the necessary changes at wordpress ( https://loveumarketing.com/fix-mixed-content-issue-website/ )

#6

Thanks man, that helped!


#7

This topic was automatically closed after 14 days. New replies are no longer allowed.