Browser Cache TTL not being respected for certain assets

It seems some of our assets are still being loaded with a Cache TTL of 7 days (which may be the origin server’s default). However, the setting in the Browser Cache TTL for Cloudflare is not being respected for certain assets. The setting in Cloudflare is 1 year.

So I’m not sure why some of these assets are still loading with 7 days. From what I can tell, it looks like the assets with a query string are loading with a year, and the assets without a query string are loading as 7 days.

How do we get them to all be 1 year?

Screenshot of current settings: https://i.imgur.com/XiJOdeu.png

What’s the URL of the asset in question? Do you have any page rules that also set browser cache TTL?

I have no page rules that are set. The domain in question is: https://freshysites.com/

Settings:

One example of an asset that is 7 days: https://freshysites.com/wp-content/themes/Impreza/fonts/fa-regular-400.woff2

Though, it’s now showing as 1 year within Chrome Dev Tools. But for some reason, when I do a PageSpeed Insights, it still shows as 7 days here: https://i.imgur.com/PWliDVI.png

Page speed insights and GTMetrix look good now.

Hmm. I’m still seeing these as 7 days from PageSpeed Insights: https://i.imgur.com/Qil3HTt.png

But GTmetrix does seem good now. I’ll assume it’s just Google not seeing the latest changes yet (fro hours ago).

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.