Browse cache differs it always shows cache-control: max-age=2592000

i have set browser cache to 1 hour in Cloudflare. however some of the assets are served for 30d. what would be the reason. here is the header

HTTP/2 200
date: Thu, 04 Apr 2024 20:12:19 GMT
content-type: image/jpeg
content-length: 25403
cache-control: max-age=2592000
cf-bgj: imgq:100,h2pri
cf-polished: origSize=25679
etag: “660cf424-644f”
expires: Fri, 03 May 2024 15:51:45 GMT
last-modified: Wed, 03 Apr 2024 06:16:04 GMT
x-content-type-options: nosniff
x-frame-options: SAMEORIGIN
x-xss-protection: 1; mode=block
cf-cache-status: HIT
age: 102033
accept-ranges: bytes
report-to: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v4?s=Ux7JmqjNvT%2FmofGJcgsApPIo52m6fiIAfYQkox3327gDc4AT58TE7oSqPbFUzWseD42gMjWDfBXm1Jrb%2FAfuU9tjYDQxuERqY%2BsYkmAJQxbHNJCHyWuR3uSpqIbWc2eU”}],“group”:“cf-nel”,“max_age”:604800}
nel: {“success_fraction”:0,“report_to”:“cf-nel”,“max_age”:604800}
server: cloudflare
cf-ray: 86f3f3debb2361c0-ORD
alt-svc: h3=“:443”; ma=86400

If you set it via the Caching → Configuration → Browser Cache TTL option, I would note the information under the Help button

Note: You can also increase the cache expiration by specifying a longer cache time on the origin server, or you can set a different Cache Expiration for a specific path or resource using the Page Rules app. Cloudflare will use whichever value is longer between your origin server cache headers and your Cloudflare setting

If you want to override Browser Cache TTL, I would recommend either lowering it from your origin, or creating a Cache Rule to override browser cache ttl.

1 Like