Brotli encoded content sent when it shouldn't be

My website (proxied through Cloudflare) is intermittently returning content (maybe 10% of the time) that is encoded with Brotli compression, even though I have the setting disabled and if using a client that doesn’t support encoding. (i.e. it doesn’t have an accept-encoding header. For example, curl)

Should this ever happen? I would have assumed Cloudflare should never send such content to a client that doesn’t indicate it can accept it.

Any suggestions as to how I can work around this issue? I’ve already tried purging my cache to no avail.


Could you possibly share a HAR (Gathering information for troubleshooting sites · Cloudflare Support docs) and a repro URL?
Feel free to email it to me walshy@

1 Like

Hi Walshy,

Can you confirm you received this ok? Do you need any more information?

I’ve Cloudflare enabled for my website for you to investigate, however I’d like to turn it off when you’ve got all the information you need, as the reported issue is causing us problems.


Interesting, we are seeing the same behaviour on one of our sites (see Cloudflare sending brotli encoded content when requesting gzip encoding). Is there any chance you’re located in the same region as we are @user62714 (central europe)?

For now we disabled brotli, flushed the cache and the issue seems to be gone. But would like to know if this is something expected or not.

We are based in the UK.

I had an email conversation with a Cloudflare representative who identified the issue and said they would work on a fix, but with an unknown timescale.

The issue we were seeing looks like it has been fixed whenever I test it with both Brotli enabled and disabled, however one of our clients is reporting the issue occurring intermittently. Unfortunately they aren’t able to give us low-level details, so I don’t know if it is this issue or something else with similar symptoms.

Thanks for the swift reply @user62714! Lets see if someone from Cloudflare chimes in on my ticket or here (@Walshy :eyes:).