Broke with Debian 12 upgrade

I have a cloudflare tunnel setup and it worked great until I updated to Debian 12. I am using docker to run and manage the cloudflared application. I do not have IPv6 enabled on my local network.

After the update to Debian 12 anytime I run the cloudflared container it adds a bunch of IPv6 stuff and brings my device’s internet connection down. Local network access still works but any attempt to access the internet is attempted over IPv6 and fails. Also the cloudflared tunnel no longer works nor is visible on the zero trust web interface.

Any suggestions would be great! Let me know if and what additional information might be helpful.

Haven’t installed and tested Debian 12 yet. Will write back with some feedback ASAP.

1 Like

This was unrelated to Debian 12. Issue was with connman service. Solution was to blocklist virtual interfaces in connman’s conf file.

If something like Docker is creating virtual interfaces Connman may attempt to connect to one of these instead of your physical adapter if the connection drops.

1 Like