Breaking error only appears on registered domain

I have a Cloudflare Pages app at https://mondstats.pages.dev. I can access this site with no issues. I have a registered domain for this app at https://mondstats.com. Here I get an error in the console “Uncaught SyntaxError: identifier starts immediately after numeric literal”. This error prevents the app from loading properly.

I’ve had the domain registered for some time and never had this issue until recently. Some users seem to be able to see the site fine at the registered domain but I the page does not load for me due to the error on my desktop and mobile. I have tried clearing all browser cache, hard refreshing, manually clearing the cache for the app in Cloudflare Pages but after performing a hard refresh the site gives me the same error.

The pages.dev version of vendor.234b542b.js has a lot of comments, so it appears that .js minification is messing it up.

Can you go to your domain’s Speed → Optimization settings at dash.cloudflare.com and turn off Auto Minify for JavaScript?

That did indeed fix the issue! Specifically it seemed to break chart.js. Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.