Brand new cloudflare and can't add products to cart

Hi there, I have a new install of cloudflare on my woocommerce site. It is about 4 hours old. I know it’s possible you are going to tell me to wait but diagnostics keeps telling me that my cname isn’t correct - screenshot here.

The undefined label is concerning. But the problem is, ajax on my site isn’t working. No one can add anything to the cart. I am losing sales every minute the site is down and I had to install cloudflare in an emerg because i have been battling a carding attack - so I have been losing sales all week.

I can’t share my URL because I have the site in maintenance mode so no one can try and fail at buying something.

Any ideas? Basically the ‘add to cart’ buttons aren’t working.

Thanks in advance,
Andrea

Sorry, I should add that the cnames have been added:

And dnschecker.org shows the cnames as having propagated.

@user18982

Have you tried:

  • Without having your CloudFlare enbled?
  • If so, do the car buttons work?
  • Have you tried reaching out to Siteground.com since it says your managed through them for your Cloudflare likley as their a Cloudflare partner?
  • Have you tried using incognito mode in Google Chrome, Mozilla Firefox, Old internet explore, Edge, or any other web browser as all?
1 Like

Thanks so much @mygsgsgroup
It has stopped working even with cloudflare disabled but… i haven’t made any edits to the site
Siteground told me to ask Cloudflare support LOL.
I have tried with incognito mode and all of the browsers but…
New Clue console reports upon adding to cart a ton of messages like this:

Access to font at ‘https://www.paracanna.com/wp-content/plugins/elementor/assets/lib/eicons/fonts/eicons.woff2?5.13.0’ from origin ‘https://paracanna.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

What does that mean? Thank you thank you. :slight_smile:

I can confirm that something weird is going on. I added a product to the cart and it showed a 1 for the cart, but when I clicked on the cart, I got an empty cart listing.

However, your DNS runs around in a circle, leading to a site that is not proxied by Cloudflare:

Now you have two issues to resolve with Siteground:

  1. Why doesn’t your cart work?
  2. Why does your DNS go around in a circle instead of ultimately resolving to ‘www’?

@user18982

Do you have any CloudFlare rules in place?
Have you tried disabling your CloudFlare?
Have you clearers your browser cache?
Have you spoken siteground support? This is a possibility that they have blocked something…

Thanks so much @sdayman - this really helped siteground and so they fixed the redirect loop. And we set up proper redirection. Once the redirection was correct, the cart functionality returned to normal.

The siteground rep had me add this to my .htacess:

Header set Access-Control-Allow-Origin: *

But I am seeing CORS errors in console for all of my fonts?

Thanks so much.
Andrea

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.