Bought Domain through Cloudflare Registrar but DNS records are blank

I’m not super experienced with domains, so since the Cloudflare DNS records are blank, my website doesn’t work.

Everywhere I read it said when you register a domain through Cloudflare, everything should be automatic but for some reason for me it isn’t.

Can anyone help me?

If you’ve bought a new domain, then there are no existing DNS records for Cloudflare to test for and import. Only when adding an existing domain to Cloudflare can it try to find records and import them for you.

1 Like

so what do I do then? because when I try to setup a simple redirect for the domain it doesn’t work. Are my DNs records automatically inputted through Cloudflare and I just can’t see them?

If you are just redirecting with no origin server, enter a dummy proxied DNS record for the domain and/or subdomain(s) you want to redirect as A 192.0.2.1 or AAAA 100::

thank you so much!

it worked on my phone, but any other device the domain redirect doesn’t work, I just get connection timed out.

What is the domain name?

This is my dns settings

Can you show a screenshot of your redirect rule?

posted above

Seems to have started working, then stopped. Have you made any changes?

https://cf.sjr.org.uk/tools/check?68ba6801d0bd4363b8f5a86bc90ff72d#connection-server
https://cf.sjr.org.uk/tools/check?a871347baee3444bb938fde9f892f59f#connection-server

It works on my pc, but not on my phones or other laptop, literally just my pc. idk whats going on, this is a a pain in the ■■■.

It is working ok for joinhu.app but was, and is now not, for www.joinhu.app which is now not resolving. Can you check the DNS record for www is still in place.

Ignore that, seems an issue with my local resolver. Both are working ok for me now…

https://cf.sjr.org.uk/tools/check?79faebdd7f3b40169dfbb8e1fa8159b9#connection-server
https://cf.sjr.org.uk/tools/check?633e2978e56641d188674bdd10342ddb#connection-server

Still doesn’t work for me.

It works on my Pc.

Phone + Tablet doesn’t work, phone on LTE doesn’t work either.

Phone and tablet are both Apple, Iphone + Ipad

Wait a while, it may be that the new domain or DNS changes need some time to propagate.

so is everything okay, then, like the settings, etc?

The setting look ok and work for me, so all seems good.

Is this normal having to wait when you buy a new domain? I’ve never really experienced this with namecheap, I know messing with dns like name servers takes some time, but is it normal for dns stuff I’ve added to take a bit of time?

You’ve been querying your domain and changing the DNS settings and 301 redirects. It’s possible something is cached at your end or resolvers you’ve been using. Without more details from the devices that aren’t connecting, I can’t tell.

All I can tell is it’s working ok for me, so the settings on Cloudflare are all ok.

1 Like