Both domains orange-clouded but 301 not working

I’m trying to redirect the www subdomain to the main (non-www) domain. Both the main domain, and the A record for www are orange-clouded. I added a page rule that matches /* and 301 Redirects to /$1 (Cloudflare won’t let me post a link in this message).

However, it is not redirecting. I confirmed Cloudflare has “control” of the subdomain by disabling the proxy it in the Cloudflare DNS, and saw that my nslookup output changed from the command line, and I got an error trying to access the www URL. So I put it back to orange-cloud.

I tried making www a CNAME instead of an A record, and same result. Any ideas?

I also tried creating a fresh new A record www2, set up the same Rule for this, and that one works. There’s just something wrong about www. Thanks for any help.

When I inspect the network response from the www version, it shows a Cloudflare cache hit. I’ve purged everything and have no cache rules set up. I’m wondering if a previous contractor on this site had a separate Cloudflare account and Cloudflare is getting confused.

Can you please share a screenshot of your page rule?

Just confirming that you mean www.example.com/* redirects to https://example.com/$1 right?

Have you seen this article?

https://developers.cloudflare.com/pages/how-to/www-redirect/

Yes, that is what I meant. I think my Community account is too new - it won’t let me post URLs. Here’s a screenshot.

That looks right to me, and yes you need to keep the DNS records :orange:

Have you tried going to your website using incognito mode, or another browser? It’s possible your browser has cached the wrong / old redirect.