Bot fight mode. .EXE Launcher API issue

Answer these questions to help the Community help you with Security questions.

What is the domain name?
[Aeon](playaeon .com/)

Have you searched for an answer?

Yes and documentation isn’t exactly helpful.

Please share your search results url:
[community.Cloudflare .com/t/Cloudflare-bot-fight-mode-blocks-wp-rocket/245868](community.Cloudflare .com/t/Cloudflare-bot-fight-mode-blocks-wp-rocket/245868)
[community.Cloudflare .com/t/bot-fight-mode-blocking-my-api-client/403967](community.Cloudflare .com/t/bot-fight-mode-blocking-my-api-client/403967)
[community.Cloudflare .com/t/bot-fight-mode-blocking-api-connection-waf-allowlisting-wont-work/427907](community.Cloudflare .com/t/bot-fight-mode-blocking-api-connection-waf-allowlisting-wont-work/427907)

When you tested your domain using the [Cloudflare Diagnostic Center](www.Cloudflare .com/diagnostic-center/), what were the results?

Describe the issue you are having:
I’m having an issue with bot fight mode activating for users trying to connect to my API. I have added numerous rules, whitelists and checks to prevent this from happening and unfortunately I do not see a way around it. I have now enabled the users to be able to touch my api without Bot fight mode enabling, however when trying to launch through my custom launcher that launches my game, when the launcher sends a request over HTTP, it flags it as bot fight mode. But only for SOME users, a very small select few. What seems to be the issue?

What error message or number are you receiving?

  • Service

Bot fight mode

  • Action taken

Managed Challenge

What steps have you taken to resolve the issue?

  1. Added custom rule to WAF for URI Full excluded point
  2. Added a Page Rule with security settings “Essentially off” to my api.
  3. Added a user-agent to my c# code to identify as a broswer and not just a random connection.

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. Go and access my API, sometimes it works sometimes it doesnt: api.playaeon .com/get-latest-version

Have you tried from another browser and/or incognito mode?

Yes. I’ve tried everything, this is specific to my launcher issue. The screenshot below will show you that the same use can access my api based on the changes i’ve made if they directly go to it through a browser, but trying to access from my launcher they get the bot fight mode.

Please attach a screenshot of the error:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.