Bluehost and 502, 520, 525 Errors when cloudflare is enabled

I am struggling…I contacted Bluehost 4 consecutive days in a row and asked them to check some of the common causes on the server end to resolve a 520, 502, and 525 SSL handshake error from

I first started with bluehost assuming it is an issue on their end due to the screenshot indicating an error on the host side. I checked my error logs and found an error in my .php file

[18-Jan-2020 13:06:28 UTC] PHP Warning: Declaration of WP_CLI\UpgraderSkin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/UpgraderSkin.php on line 59

I asked bluehost customer support team to update my php file which they did, however, it did not fix the issue.

Below’s one of the screenshots of the error I receive with Cloudflare enabled. If i refresh the browser it usually gets through and renders the site, these errors appear about 1/7 attemps.

However, when I pause Cloudflare on my site, I do not get 520 or 502 SSL handshake error.

Bluehost then mentioned I may need to pay for a dedicated SSL certificate, but I don’t know how to confirm it will fix this issue?

My site is I’ve had Cloudflare for 18 months or so and this is the first time I am having an issue, started on January 18th.

Thank you for the help, really appreciate it!!!

I don’t think that PHP Warning is related. I’ve seen a few of those exact ones on my sites.

Are you saying that you don’t have valid SSL at your host?

I did ask bluehost to confirm if there are any issues with my SSL and they said there wasn’t.

I am using the auto SSL, the free version from Bluehost I believe…

AutoSSL is ON

  • AutoSSL provides free domain-validated certificates for all your domains and subdomains.
  • Premium certificates can be purchased below with or without AutoSSL.

They mentioned I may need to buy a better SSL?

I am also wondering if I should remove cloudfare and start from scratch

This topic was automatically closed after 14 days. New replies are no longer allowed.