Bloqueos en mi lms

Buen día, tengo un lms alojado en azure, con DNS generado por azure, vinculado a un subdominio de un tercero, mediante un cname y con un SSL emitido por Go Daddy, y recibo mensajes de bloqueo desde Cloudflare, revisando el inspector veo que específicamente

/lib/ajax/service-nologin.php

y la página de bloqueo me manda este enlace: Cloudflare Ray ID: 733fbd76bed64ffa

adicionalmente he recibido este jason

“action”: “block”,
“clientASNDescription”: “GOOGLE-FIBER”,
“clientAsn”: “16591”,
“clientCountryName”: “US”,
“clientIP”: “XXXXX”,
“clientRequestHTTPHost”: “XXXXXX”,
“clientRequestHTTPMethodName”: “GET”,
“clientRequestHTTPProtocol”: “HTTP/2”,
“clientRequestPath”: “/lib/ajax/service-nologin.php”,
“clientRequestQuery”: “?info=core_output_load_fontawesome_icon_system_map&cachekey=1658337188&args=%5B%7B%22index%22%3A0%2C%22methodname%22%3A%22core_output_load_fontawesome_icon_system_map%22%2C%22args%22%3A%7B%22themename%22%3A%22adaptable%22%7D%7D%5D”,
“datetime”: “2022-07-27T17:55:35Z”,
“rayName”: “73173f346dad2f3d”,
“ruleId”: “6179ae15870a4bb7b2d480d4843b323c”,
“rulesetId”: “4814384a9e5d4991b9815dcfc25d2f1f”,
“source”: “firewallManaged”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36”,
“matchIndex”: 0,
“metadata”: [
{
“key”: “ruleset_version”,
“value”: “77”
},
{
“key”: “version”,
“value”: “76”
},
{
“key”: “type”,
“value”: “customer”
},
{
“key”: “score_total”,
“value”: “47”
},
{
“key”: “score_rules”,
“value”: “["a6be45d4905042b9964ff81dc12e41d2","ac090cd641d742b3adba4ece7f4d7e64","f2db062052cf453fbe9e93f058ecf7e7","6afe6795ee6a48d6a1dfe59255395a78","f394c2277cba4406b408c9d1feb8fadb","5a6f5a57cde8428ab0668ce17cdec0c8","5e4903d6afa841c9b88b96203297003f","2380cd409b604c2a9273042f3eb29c4e","f5aebedc99a14c8d9e8cfa2ce5f94216","edf8c37cc81747d382690b3c77e82ce4","1129dfb383bb42e48466488cf3b37cb1"]”
}
],
“sampleInterval”: 2

Me han dicho que se debe a las reglas OWASP y están fijadas en 40 puntos y mi LMS supera ese valor. Entonces necesito saber que hacer para que mi LMS funcione. De hecho si accedo desde la DNS que me proporciona Azure todo trabaja perfectamente. Ayuda porfavor

¡Hola @teksukamen!

Por favor revisa y sigue https://support.cloudflare.com/hc/es-es/articles/200172016-Reglas-administradas-del-WAF-Firewall-de-aplicaciones-web-#sJbboLurEVhipzWYJQnyz
Espero esto te sea de utilidad.

¡Gracias!
Alex

Hola Alex, gracias por tu respuesta, dime tienen reglas para Moodle?

Hola Alex, he revisado el enlace, pero documentación sobre las reglas WAF, no tengo control en esa parte, quiero saber si desde mi lado en mi servidor de azure con moodle algo puedo hacer