Blogspot Feedburner RSS not working with Cloudfare

It took a great deal of testing to confirm that this problem is originating from my cloudfare and not my feedburner account.
I have a feedburner account linked to my blogspot blog with a custom domain [www.knowseeker.com] linked to Cloudfare. After connecting my domain above to Cloudfare, I noticed that my feedburner feeds stop updating with a 404 url not found error in feedburner.

I have tried a lot of settings on Cloudfare to no avail but I hope this is sufficient information for now. Please, I need help with this.

Look once at Cloudflare Firewall log. If any chance it is blocking, you can fix it.

1 Like

I just checked the logs. I don’t say anything related to feedburner in my firewall.

Try one thing

Add a page rule in Cloudflare

*example.com/*feed*

Cache: Bypass

See if this help.

I’ve tried that earlier and I got the error that my domain www.knowseeker.com must begin the url, but my feedburner url is http://feeds.feedburner.com/KnowseekerBlogForLifestyleHealthRelationshipsExcellenceEtc

Is there a way I can create a redirect to a non-existent url like mydomain/feeds to my feedburner url and add it as a page rule?

Sorry, I am including many links. It’s the best way I could simplify the issue.

Yes, put own domain instead feedburner

Done. Did not work. Should I wait a little longer?

Please, I still need help with this. I updated the page rules but it still won’t work. Any more recommendations, guys?

Was that domain using HTTPS before you added it to Cloudflare?

Also, 404 errors are from the host, so you might see something in your webserver logs.

Yes, it was.
Okay, let me do some more checks then. Thanks for your prompt response, sdayman. :+1:

1 Like

I am on using blogspot, I don’t think checking the server logs is possible. Do you know a way I can check the logs?

I’m having a hard time tracking down how your feed actually works. The rss feed in your site’s header is:
https://www.knowseeker.com/feeds/posts/default?alt=rss

But it looks like you have a Page Rule that redirects it to:
http://feeds.feedburner.com/KnowseekerBlogForLifestyleHealthRelationshipsExcellenceEtc (and this returns a feed)

And it seems that your site is hosted by Blogspot. So…what’s the source URL of the feed you’re trying to publish?

EDIT: And it looks like that feedburner feed is way behind…maybe because the 404 problem you mentioned…so…now I’m completely lost as to where your RSS feed is really supposed to originate.

I tried to understand that too but you just made me understand it better now.

My feeds are updated by feedburner when I publish a new post. Blogger automatically redirects my knowseeker to my feedburner url and notifies my subscribers as the new feeds are updated when I publish a new blog post.

Normally, this worked fine before I connected to cloudflare and it works when I replace the cloudflare nameservers with the defaults. But when I am connected to cloudflare, I get 404 errors in feedburner troubleshootize.

What can I do?

It looks to me like my feedburner url is not accessible to the cloudflare servers.

Sorry if I have not mentioned this. The source url I am trying to publish is the feedburner url http://feeds.feedburner.com/KnowseekerBlogForLifestyleHealthRelationshipsExcellenceEtc

Does that Feedburner 404 tell you what the URL is that’s not working?

Also, in the Feedburner setup instructions, it mentions a, “Identify Feed Source” page. Do you know what that was? It still seems to me that your site’s feed should not redirect to Feedburner, as that’s probably how Feedburner needs to pull its content.

Okay. The feed source is https://knowseeker.blogspot.com/feeds/posts/default

Well, that gives me a 404.

Man, you are too much. I just updated my original feed url from https://www.knowseeker.blogspot.com/… to https://www.knowseeker.com/… and the 404 error was removed.
Hope that means the feeds are synced now? Could you re-query that again?
I hope its fixed now.

Thank you so much, sdayman. I would never have gotten this without your help.