Blocking with Firewall Tools Doesn't Work

I’m trying to use the Firewall Tools, IP Access Rules section to block access to my site from a certain country. I have referenced the help page but this looks more like a bug.

I entered the country, kept the default block, default website selection, added a note, and clicked Add, but nothing happens. It doesn’t get added. I was successfully able to add a JavaScript challenge rule however. I then tried to change that rule from JS Challenge to Block. It looks like it works, but then I refresh the page and it just hangs forever, white page with a spinner icon. I navigate back to the main dashboard, then back to the IP Access Rules section, and the change hasn’t been saved, it’s the original JS Challenge selection.

I can see the rule, it may have been a temporary glitch, log out, login and try again. If that does not work, check to make sure you don’t have any adblocker running and/or try from a different browser/incognito tab and see if that has any effect. I don’t see any issues in #cloudflarestatus that would explain the issue you’re seeing. Let us know how it works.

I had already disabled my adblocker, had no effect. Just now, I tried:

  • Logging out and back in
  • Logging in through Safari (not my main browser, no extensions or cache/cookies)
  • Logging in through Safari Private

All had the same behavior as initially described, both for adding a new rule or trying to change the existing one back to “Block”. When you say you can see the rule, is it the JavaScript Challenge rule?

This topic was automatically closed after 30 days. New replies are no longer allowed.