Blocking user Agent is not working

Hello everyone, I just blocked the following user agent and somehow the user is by passing the block.

“Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0”

    • [30/Nov/2018:17:22:33 +0100] “GET /Chat.php HTTP/1.1” 200 3360 “http://mysite.com/” “Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0”

any idea of how to block this user agent ?

There is a good chance they are bypassing Cloudflare altogether and connect directly to your site.

Thank you for your reply.
You mean there is something wrong with the setting or it’s just a flaw ?

It is neither a flaw nor a problem with the setting, whoever browses your page probably bypasses Cloudflare and hence it wont take effect.

I am running. Chat server and I have tried blocking mobile user’s useragent and it works perfectly, but the user agent blocking for desktop users doesn’t work, I tried blocking myself and without Any effort I was able to connect to the site.

What URL are we talking about?

Did you specify the blocked user agent with or without quotes?

Url

And here is a screenshot of the entry

Is that all or is it truncated? It does not show the same user agent as what you mentioned above.

Yes Indeed this is not the same useragent, this one is mine and I used this for testing purposes

This is not a user agent, unless you configured a very obscure custom user agent on your own.

Which user agent is currently blocked?

This topic was automatically closed after 30 days. New replies are no longer allowed.