Blocked font by cors policy: no 'access-control-allow-origin'

Hi Community,

I need your help please. I have a wordpress site. But I added a custom built page to it and I only get a font error on the custom built page, which is https://www.elysian-management.com/voice.html. My font isnt working at all. When you go to the Home, About Page and Contact you’ll see the font is working perfectly as these pages are all done in wordpress/elementor.

Please see the errors below:

I dont even know what to do about this. I am not advance in development. So would need some guidance here please.

Thanks so much for reading.

Your site responds to two hostnames: www, and without www. You’re probably using Chrome and it’s not showing ‘www’ in the address bar (sucky unhelpful feature by Google), and it’s not matching the hostname for the fonts.

Two fixes:

  1. Set a canonical URL (The “make up yer darned mind hostname”). Usually WordPress Settings → General shows this, or you can set it in wp-config.php.
  2. Easier fix:
2 Likes

Thanks so much for this. I will give it a try and let you know if its worked :smiley:

Just a quick question. Do I have to make a new A record for the www? Because I already have a CNAME for the www

Thanks,

No need for that additional “A” record. You already have a CNAME set to :orange:, so the Page Rule will still take effect.

1 Like

I did this. And now I am getting an error Saying “The page isn’t redirecting properly”

sorry my bad!!! I was doing the whole site LOL. instead of just the voices page

Well that’s weird. The whole thing should be consistent. I don’t know why your site would get stuck in a redirect in some places, but not others.

What’s the Canonical URL in your Settings -> General section? Is it with the www, or without?

This is what mine is showing.

Then I don’t know why it’s trying to load fonts without the WWW. Maybe the theme developer can explain why. And it’s a mystery why the main site will redirect to www, but just that page won’t.

This isn’t how it should behave, and it’s not a Cloudflare issue. At least Cloudflare Page Rules can band-aid the problem, but your site needs some adjustments to use a consistent hostname. Again, maybe the theme developer can help.

This topic was automatically closed after 14 days. New replies are no longer allowed.