Blazor.NET app not working with cloudflare

I have created in Visual Studio a Blazor .net app ( running on a custom domain via Microsoft Azure. It’s just de default template app.

The first time the app is working and buttons are responding. As soon as the page gets cached by Cloudflare it stops working. The webpage is visible but all buttons and links do not respond.

When I turn on “Development” Mode in Cloudflare everything works again.

I have tried to create Rules to bypass the cache in Cloudflare. Unfortunately this doesn’t work either.

Has anyone experience hosting a blazor .net app via Cloudflare?

Can you post a picture of the Bypass Cache page rule you tried?

Does anything show up in Firewall Events log? If it’s a web-based app, can you take a look in your browser’s Dev Tools (F12 in Chrome) at the Console log?

There’s also a chance you’re using JavaScript, and Rocket Loader isn’t compatible with your particular setup. You can toggle Rocket Loader in the Speed tab’s Optimization section.

It’s not showing anything in the Consolo Log. I’m not using Rocket Loader.

This topic was automatically closed after 14 days. New replies are no longer allowed.