Blank page interrupts load of page

Our website www.zonz.nl behaves strangely:

Opening any page on the site results in first displaying the page shortly, seconldy a blank page is shown, thirdly the page is fully loaded.

We already temporarily disabled GTM but the issue persists.
Cloning the entire website to a temporary domain without CF enabled does NOT show this issue. Seems it is not an issue with the code.

Currently Cloudflare has been enabled for this site. Still the issue is present.

What can be the cause of this issue? Thank you very much for your support.

Did you hope that Cloudflare will fix that problem?

I am sorry to say, but your problems seem to me to be completely unrelated to Cloudflare. Please try to set Cloudflare into developer mode, then try again, if the same thing happens please hire a web developer. If it disappears I am more than happy to look into this.

Are you the siteowner, or the developer?

Thank you for your reply @M4rt1n, am happy you’re of support to us.

We’re technical partner of the site owner. And have been digging in this issue for days now together with a developer.

Cloudflare has been active on the domain for years, without issues.

Issue did not occur to a 100% clone of the website running on a develop domain, that’s why we thought something is wrong with our Cloudflare environment. Putting on Cloudflare into developer mode does not take away this issue, unforunately.

Then Cloudflare did not create this issue, it already exists at/on the origin.

This does not overrule my previous statement. This is not an issue created by Cloudflare.

That means, the site owner pays you for fixing that problem. Outsourcing for free what you get paid for is kind of rude, I think. If you know that putting Cloudflare for this specific site in developer mode does not fix the problem, you basically already know that Cloudflare did not produce that error.

Hint: your problem stems from JS files and re-rendering :slight_smile:

Thank you @M4rt1n for your reply. We’re pleased that you have spend time to help us further. It was not our intention to be rude by asking support from an Cloudflare expert like you. Thank you once again.

Putting the zone in Development Mode does not bypass Cloudflare, its still proxied through Cloudflare is its not accurate to say that Development Mode can rule out Cloudflare entirely. That said, it’s likely an issue in the origin or site.

1 Like

Don’t worry, I just want to figure out where the problem roots from. Since problems shall be fixed by their origin. If Cloudflare would be involved I would be more than willing to help you.

It is in this case, since all requests are fast for me (30ms TTFB) and this still this happens - the only thing that could involve Cloudflare would be modifying/altering files by compression or minifying. Everything else in this case is indeed ruled out. Since Cloudflare in developer mode does not even touch files, nor existing headers (beside the server header) I think I have ruled out Cloudflares involvement in this issue.

If you have a closer look at the performance chart in the “Performance Insights” section in the dev tools:


you can easily tell why and what is causing this.

Hint for @develop3: please disable all plugins one after another and each time clear the entire cache & try again. This will lead you do the plugin causing this.
You also are using “Kinsta”. I have never used them, nor do I have expirience with them, but check, that they are not modifying anything.

And in genral for any Wordpress setup we recommend using APO for TTFB improvement.
Try to disable RocketLoader, but in developer mode it already is disabled, so will not be the culprit … at least not this time.

1 Like

Seems like this is not true, since in developer mode RocketLoader should not be invoked.

My further analysis of the “Performance Insights” have shown that the issue again stems from Cloudflares JS-Based performance products.

@develop3 please disable RocketLoader, then clear cache and try again. My tests did show that:

  1. the problem indeed stems from a JS triggered re-rendering
  2. the re-rendering gets invoked pretty late
  3. the re-rendering gets invoked by RocketLoader

Your analysis about “the same problem occuring in developer mode” must be wrong, but that does not matter anymore. Do as described above and please report back.

1 Like

Proof of RocketLoader beeing the problem:

Thank you so much for your further investigation @M4rt1n as disabling Rocketloader solved the issue! Vielen Dank! :wink:

1 Like

Just out of curiosity: does the problem occure in developer mode with RocketLoader enabled?

You are welcome!
Gern geschehen :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.