Blank page after turning on CDN and HTTP proxy

Thanks for the warning.

Currently, it’s bypassing Cloudflare.

I suggest you use Chrome’s Dev Tools (Hit F12 to open this) and watch the Console for errors. You can also check the Network tab in Dev Tools to see what’s loading and what’s not.

I disabled Cloudflare since it’s rendering my site unresponsive. I’ll turn on Cloudflare now, so check it out in a few if you can, please.

It’s not blank for me. Try clearing your browser or switch to a different one.

Is it blank for others as well?

Remove cache and try switching IP’s or use a proxy.

I tried with a VPN, same blank page…

What’s that on the right side? It doesn’t look like a scroll bar. Disable Rocketloader and try again. If it stays that way play around with the other options like Auto Minify. It looks like something breaks a JS

It’s not working for me on Chrome in any mode.

(Just saw Mark’s response. I hope that fixes it)

EDIT: My screenshot from earlier was on Firefox.

It’s Samsung 8’s edge screen feature.

Disabled all Auto Minifies, Rocket Loader was never turned on. Everything worked fine before Saturday.

I just got: Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR

Now I’m just guessing here:
Can you go to the Cloudflare SSL/TLS settings and turn off TLS 1.3 (it’s down a bit).

What’s your Minimum TLS Version set to (also on Crypto page)?

While we’re at it, can you try the Firefox browser on your phone?

I’ve set it to 1.1, now it’s at 1.0

And TLS 1.3 is off? Have you tried Firefox on your phone?

At this point, you should open a Support Ticket since we can replicate the problem, but not isolate it: login to Cloudflare and then contact Cloudflare Support.

hi guys
i have very high ranked adult website and i had this problem from 4 days until now , i tried everything u can imagine , the server works when cdn/proxy disabled but since my website have many competitors i got ddos attack after i work with real ip , so i keep sending to cloud flare support and keep getting silly answer like ur response have vary user agent and even this i changed to accept encoding
the problem that this blank page appears only in chrome and opera , edge , but fire fox working normally
and this forum is the 3 person i see have same problem i moved to another cdn less quality higher price and have some issues , but nothing in my hand and in non peak times i try to change to cloud flare and test and same results even deleted website from cloud flare and added back nothing changed even added it to different cloud flare , nothing changed , the har file in chrome show the error as socket error this error known to be happen at nginx webserver most of times and my web server is apache so its clear that there are something
wrong in nginx servers of cloud flare , and specially with rocket loader and js , the only once that my website open in chrome in cloud flare after this happen was after turning rocket loader on and when i refreshed same problem again and keep trying all variation of enable /disable rocket loader , br etc , nothing changes
anyway please if any of u find a soultion to the problem send me please at my email [email protected]

thanks

So here’s a suggestion for both posters:
Create a Page Rule to match example.com/ (To match the entire website).
Add Settings to disable all kinds of stuff:

  • Cache Level: Bypass
  • Disable Apps
  • Disable Performance
  • Disable Security
  • Rocket Loader: Off
  • Security Level: Essentially Off

Maybe something in one of these settings is interfering. It that helps, start removing those settings in the Page Rule one by one.

1 Like

Problem is that everything worked perfectly fine for a month, but on Saturday it broke. I didn’t touch anything related to the settings for a month.

That’s always a mystery when that happens. Obviously, something changed. You could contact Support to see if they know what might have caused the issue: login to Cloudflare and then contact Cloudflare Support.

One option that’s over my head is to get a HAR file from Chrome and send it to Support. That may pinpoint the error.

hi
i finally found a solution for the problem , by the way my website run for 10 months cloud flare with no problems
or changes in important settings , anyway
i will write down the option to ONLY enable and other option disable them and this will fix problem for
and keep in mind after 4 days of problem with me and 100s of tests the problem not from one option
its from 3 options combined u have to disable :
1- Crypto > Automatic HTTPS Rewrites > OFF ,(main source of problem), if you need to rewrite from non
www to www or from http to https , u have to do this in htaccess file in apache and i if u need help i can write
u here what lines u have to add .
2- Rocket loader OFF (main source of problem)
3- Brotli (problematic also especially when your apache server did not had mod_brotli installed

SSL/TLS settings:

  • SSL > FULL
  • Always use HTTPS > On
  • Minimum TLS Version > TLS 1.0 (default)
  • Opportunistic Encryption > Enabled
  • TLS 1.3 > Enabled
  • Automatic HTTPS Rewrites > OFF

FireWAll Settings:

  • Security Level > Medium
  • Challenge Passage > 30min

Speed Settings (VERY iMPORTANT!):

  • Enable Accelerated Mobile Links > enabled
  • Auto minify > Disabled (but you can use it if you like )
  • all Other speed settings is off

Caching Settings :

  • Caching Level > Standard
  • Browser Cache Expiration > Respect existing headers
  • Always Online > ON

Page Rules settings :

  • None

Network Settings :

  • HTTP/2 > On
  • IPv6 Compatibility > On
  • IP Geolocation > On
  • Maximum Upload Size > 100mb

Traffic settings:

  • none

test like this and tell me the results
best of luck :sunglasses:

Doesn’t work for me.

Support told me this

Hi there,

I tested your website with Cloudflare on and this is what I got:

curl -svo /dev/null https://streampleasure.xyz

  • Rebuilt URL to: https://streampleasure.xyz/
  • Trying 2400:cb00:2048:1::681f:5150…
  • Connected to streampleasure.xyz (2400:cb00:2048:1::681f:5150) port 443 (#0)
  • found 148 certificates in /etc/ssl/certs/ca-certificates.crt
  • found 592 certificates in /etc/ssl/certs
  • ALPN, offering http/1.1
  • SSL connection using TLS1.2 / ECDHE_ECDSA_AES_128_GCM_SHA256
  •    server certificate verification OK
    
  •    server certificate status verification SKIPPED
    
  •    common name: sni214195.Cloudflaressl.com (matched)
    
  •    server certificate expiration date OK
    
  •    server certificate activation date OK
    
  •    certificate public key: EC
    
  •    certificate version: #3
    
  •    subject: OU=Domain Control Validated,OU=PositiveSSL Multi-Domain,CN=sni214195.Cloudflaressl.com
    
  •    start date: Tue, 19 Jun 2018 00:00:00 GMT
    
  •    expire date: Wed, 26 Dec 2018 23:59:59 GMT
    
  •    issuer: C=GB,ST=Greater Manchester,L=Salford,O=COMODO CA Limited,CN=COMODO ECC Domain Validation Secure Server CA 2
    
  •    compression: NULL
    
  • ALPN, server accepted to use http/1.1

GET / HTTP/1.1
Host: streampleasure.xyz
User-Agent: curl/7.47.0
Accept: /

< HTTP/1.1 200 OK
< Date: Tue, 17 Jul 2018 11:16:01 GMT
< Content-Type: text/html; charset=UTF-8
< Transfer-Encoding: chunked
< Connection: keep-alive
< Set-Cookie: __cfduid=df3605465009308ea74c6afe9ccc73c3d1531826161; expires=Wed, 17-Jul-19 11:16:01 GMT; path=/; domain=.streampleasure.xyz; HttpOnly
< Expires: Thu, 19 Nov 1981 08:52:00 GMT
< Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< Pragma: no-cache
< Set-Cookie: AVS=b1ecbf85056ed3ee3ae7ecbf613391ff; path=/
< Last-Modified: Tue, 17 Jul 2018 11:16:01 GMT
< Strict-Transport-Security: max-age=31536000; includeSubDomains; preload
< X-Content-Type-Options: nosniff
< Expect-CT: max-age=604800, report-uri=“https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct
< Server: Cloudflare
< CF-RAY: 43bc4b479d59345e-LHR
<
{ [575 bytes data]

  • GnuTLS recv error (-110): The TLS connection was non-properly terminated.
  • Closing connection 0
    It is very strange that there is a GnuTLS error happened, GnuTLS recv error (-110): The TLS connection was non-properly terminated. This should be the reason that we are getting a blank page here.

Would you able to check on your origin server if the GnuTLS has been well implemented?

Best Regards,

Qia | Technical Support Engineer

I don’t get why everything is fine when you bypass Cloudflare, but Chrome breaks when you use Cloudflare.

At this point, I would go to the Cloudflare Crypto page and click Disable Universal SSL at the bottom. Wait 5 minutes, then click Enable Universal SSL. I’m hoping it’s just a broken SSL certificate.

You should be able to do the above while still bypassing Cloudflare. Once you have an Active certificate again, re-enable Cloudflare.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.