Blank page after turning on CDN and HTTP proxy


#1

There is a blank page every time I turn on the CDN and HTTP proxy (orange cloud), which breaks my site. Happens only with cloudflare, origin works perfectly fine. Started happening on Saturday. What to do? Sent support ticket, no answer.


Blank page after turning on CDN
#2

What’s the domain?


#3

Caution, it’s an xxx site: https://streampleasure.xyz


#4

Thanks for the warning.

Currently, it’s bypassing Cloudflare.

I suggest you use Chrome’s Dev Tools (Hit F12 to open this) and watch the Console for errors. You can also check the Network tab in Dev Tools to see what’s loading and what’s not.


#5

I disabled cloudflare since it’s rendering my site unresponsive. I’ll turn on cloudflare now, so check it out in a few if you can, please.


#6

It’s not blank for me. Try clearing your browser or switch to a different one.

Is it blank for others as well?


#7

Remove cache and try switching IP’s or use a proxy.

I tried with a VPN, same blank page…


#8

What’s that on the right side? It doesn’t look like a scroll bar. Disable Rocketloader and try again. If it stays that way play around with the other options like Auto Minify. It looks like something breaks a JS


#9

It’s not working for me on Chrome in any mode.

(Just saw Mark’s response. I hope that fixes it)

EDIT: My screenshot from earlier was on Firefox.


#10

It’s Samsung 8’s edge screen feature.

Disabled all Auto Minifies, Rocket Loader was never turned on. Everything worked fine before Saturday.


#11

I just got: Failed to load resource: net::ERR_SPDY_PROTOCOL_ERROR

Now I’m just guessing here:
Can you go to the Cloudflare Crypto settings and turn off TLS 1.3 (it’s down a bit).

What’s your Minimum TLS Version set to (also on Crypto page)?


#12

While we’re at it, can you try the Firefox browser on your phone?


#13

I’ve set it to 1.1, now it’s at 1.0


#14

And TLS 1.3 is off? Have you tried Firefox on your phone?

At this point, you should open a Support Ticket since we can replicate the problem, but not isolate it: support AT cloudflare DOT com
or https://support.cloudflare.com/hc/en-us/requests


#15

hi guys
i have very high ranked adult website and i had this problem from 4 days until now , i tried everything u can imagine , the server works when cdn/proxy disabled but since my website have many competitors i got ddos attack after i work with real ip , so i keep sending to cloud flare support and keep getting silly answer like ur response have vary user agent and even this i changed to accept encoding
the problem that this blank page appears only in chrome and opera , edge , but fire fox working normally
and this forum is the 3 person i see have same problem i moved to another cdn less quality higher price and have some issues , but nothing in my hand and in non peak times i try to change to cloud flare and test and same results even deleted website from cloud flare and added back nothing changed even added it to different cloud flare , nothing changed , the har file in chrome show the error as socket error this error known to be happen at nginx webserver most of times and my web server is apache so its clear that there are something
wrong in nginx servers of cloud flare , and specially with rocket loader and js , the only once that my website open in chrome in cloud flare after this happen was after turning rocket loader on and when i refreshed same problem again and keep trying all variation of enable /disable rocket loader , br etc , nothing changes
anyway please if any of u find a soultion to the problem send me please at my email [email protected]

thanks


#16

So here’s a suggestion for both posters:
Create a Page Rule to match example.com/ (To match the entire website).
Add Settings to disable all kinds of stuff:

  • Cache Level: Bypass
  • Disable Apps
  • Disable Performance
  • Disable Security
  • Rocket Loader: Off
  • Security Level: Essentially Off

Maybe something in one of these settings is interfering. It that helps, start removing those settings in the Page Rule one by one.


#17

Problem is that everything worked perfectly fine for a month, but on Saturday it broke. I didn’t touch anything related to the settings for a month.


#18

That’s always a mystery when that happens. Obviously, something changed. You could contact Support to see if they know what might have caused the issue: support AT cloudflare DOT com
or https://support.cloudflare.com/hc/en-us/requests

One option that’s over my head is to get a HAR file from Chrome and send it to Support. That may pinpoint the error.


#19

hi
i finally found a solution for the problem , by the way my website run for 10 months cloud flare with no problems
or changes in important settings , anyway
i will write down the option to ONLY enable and other option disable them and this will fix problem for
and keep in mind after 4 days of problem with me and 100s of tests the problem not from one option
its from 3 options combined u have to disable :
1- Crypto > Automatic HTTPS Rewrites > OFF ,(main source of problem), if you need to rewrite from non
www to www or from http to https , u have to do this in htaccess file in apache and i if u need help i can write
u here what lines u have to add .
2- Rocket loader OFF (main source of problem)
3- Brotli (problematic also especially when your apache server did not had mod_brotli installed

Crypto settings:

  • SSL > FULL
  • Always use HTTPS > On
  • Minimum TLS Version > TLS 1.0 (default)
  • Opportunistic Encryption > Enabled
  • TLS 1.3 > Enabled
  • Automatic HTTPS Rewrites > OFF

FireWAll Settings:

  • Security Level > Medium
  • Challenge Passage > 30min

Speed Settings (VERY iMPORTANT!):

  • Enable Accelerated Mobile Links > enabled
  • Auto minify > Disabled (but you can use it if you like )
  • all Other speed settings is off

Caching Settings :

  • Caching Level > Standard
  • Browser Cache Expiration > Respect existing headers
  • Always Online > ON

Page Rules settings :

  • None

Network Settings :

  • HTTP/2 > On
  • IPv6 Compatibility > On
  • IP Geolocation > On
  • Maximum Upload Size > 100mb

Traffic settings:

  • none

test like this and tell me the results
best of luck :sunglasses:


#20

Doesn’t work for me.