Bizarre HTML rewriting bug with duplicated h1 text

Cloudflare rewrites


to be


in static html file when the page is loaded. If I turn on “Development Mode” for the domain then the issue goes away completely, and when I turn “Development Mode” off then it comes back. It is duplicating text inside h1 tags and td tags but not h2 tags or p tags. Purging the whole cache does nothing to change this issue.

This suddenly started happening today with no configuration changes made by me in a long while. I noticed a bunch of text duplicated on a page and ruled out PHP as a possibility since it even happens in a regular static HTML file. So bizarre.

I am certainly tempted to upgrade my account to tell a support person but feels this is so hilariously absurdly bad I thought I might as well share it with everyone.

1 Like

The team from Support is part of the Community. Can you share the domain/page where you are seeing this?

Thanks! Yes, here is an example of a static page where the HTML is just "


" but is rewritten:

I had the same issue this afternoon. A page we use internally, which has been using Cloudflare for as long as I can remember, started duplicating text on the page. To test I created a very simple HTML file with one word which was ‘Date’ and the output was ‘Date Date’. I found switching on developer mode stopped the behaviour but obviously this removes the benefits of using Cloudflare.

Having searched around, someone else has also had this issue last month but the thread it’s in doesn’t apply to my situation:

1 Like

Thank you @mike150 & @sausagehotdog.

The only similar instances to this behavior that I found were related to a compatibility issue with woocommerce and occasionally wp rocket or combination of other plugins. There was no commonality around remediation aside from disabling plugins.

Thank you @mike150 @sausagehotdog we appreciate you letting us know. This helped us identify & resolve a recent issue. Can you verify that you are no longer seeing the issue? The test.html file loads correctly for me.


All fixed now, thanks!!


Thanks @cloonan - we’ve disabled developer mode and re-enabled Minify and Brotli. It seems to be working as expected. Appreciate your help with this. :+1:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.