Beware the new WARP/ZT client on windows 2023.03.381.0 - broken

I’ve reported this as a feedback to CF but as a service to the community I’ll post all the new bugs in the new version I’ve found here as well as you don’t end up in an outage. I strongly suggest you do not upgrade to the new client.

  1. (Critical) WARP disconnects and reconnects every 10-30 or so seconds, unable to pass traffic
  2. (Major) The WARP application crashes hard every ~30-60 seconds of this connecting and reconnecting. It needs to be restarted to be able to interact with it again.
  3. (Major) The new versions considers virtual ethernet devices (e.g. Hyper-V) to be wired networks and if the option to disable WARP on wired networks is selected it won’t try to connect. You have to turn off the disable for wired and configure extra split tunneling to be able to connect which may or may not work for your network layout.
3 Likes

Hello there,

Did you perhaps log a ticket with Support?
Can you provide a ticket number?

Thank you.

Hi, the ticket is 682730

Hi again,

I am not able to find any ticket with that reference number.

Can you please help me check if you opened a ticket via the dashboard?

The ticket number would be 7 digits.

No, not via the dashboard but via the feedback feature in the warp client. That is the reference ID I got in the email response.

Hello,

Got it, would you be able to log a Support ticket for me please?
I will be able to escalate this to ZT Team faster, and would you be able to get a warp diag file attached with the trouble occurring to the Support Ticket?

Thank you.

You’re right! I thought either CF was having outages or my ISP is playing tricks on me.

I went back to the previous v2022.12.582.0 and it’s working great.

Anyone tried the beta v2023.3.387.1 yet?

I can firm this is the case for 2023.3.381.0 and rollbacks to previous releases resolves the problem. WARP in the current general release is broken.

1 Like

+1 here - roll back to previous version and everything springs back to life.

same here roll back to previous version fixes issue.

Same here. Rollback to December, everything ok.

From my testing the Version 2023.3.412.0 does not fix this, the problem remains.

1 Like

I can confirm that 412 is still broken as well. Just had to rollback.

@oshariff (apologies not sure the etiquette on here with regards to tagging CF staff) - is it worth me opening a separate support ticket?

3 Likes

412 is broken for us too.

I can also confirm the same Connecting / Disconnecting with .381. Not ALL devices…but some. Can’t find a rhyme or reason to why it’s affecting certain devices, but it’s an issue for sure. Checked Network Adapters, rolled back drivers, disabled IPv6 for testing, etc…nothing worked, so def a bug. Ticket ID: #2763489 Provided warp-diag logs from an affected device.

We are experiencing the same problem on multiple devices. This needs to be fixed ASAP.

1 Like

Any updates on this yet?

1 Like

@matt138 Yes, a separate ticket is better for Engineering.

Thank you.

@sadlerd Apologies on the late response. I have an update from Engineering and I have just updated your ticket.

They do see some strange stuff, but unable to pinpoint the trouble at this moment. Do help us with the steps in the ticket.

Thank you.

@mgonzalez Do you have a Support ticket opened for 412?

Thank you.