wie kan mij hierbij helpen?
heb ik mijn Cloudflare account ssl et cetera goed in gesteld?

Secure connection failed

Error while connecting to (my domain name) Unable to communicate securely with peer: no common encryption algorithm(s).


The page you want to view cannot be displayed because the authenticity of the data received could not be verified.
Please contact the website owners to inform them of this issue.

Was your site secure before you used Cloudflare?

I just bought the domain name from a hosting company in the Netherlands where I live.

I have set everything up via the website of the hosting company as described at Cloudflare …

my domain name needs to be redirected to a webshop:
at pixels i can’t put the URL here…

I bought .com 9can’t put the URL here) address to stop using pixels in the name.

What’s the domain?

Cloudflare don’t allow URL in messages

screenshot cloudflare|666x499

1 Like

Your DNSSEC setup is not correct and you should disable that at your registrar or set the values provided by Cloudflare.

Also, make sure your encryption mode on Cloudflare is Full Strict, as otherwise your site would be without encryption.

1 Like

hello thanks i’d correct to fullstrict…
see screenshot Cloudflare account.

of the institution at the hosting company in the Netherlands I think I have set this correctly, but I will check it and then send you a screenshot of those settings

Unfortunately, your server is not secure. You best pause Cloudflare now and fix the server certificate, once that works, it will also work on Cloudflare.

And you need to fix DNSSEC as mentioned.

In this order

  1. Pause Cloudflare
  2. Fix DNSSEC
  3. Fix your server certificate

Once your site loads fine on HTTPS, you can unpause Cloudflare, not before.

I have disabled DNSSEC via my hosting page
see screenshot

You haven’t completed the first step.

Fix DNSSEC (where should I do that?, I set this to ‘off’ at the hosting company in the Netherlands).

Fix your server certificate; (where to do this at the hosting company in the Netherlands account?) if so I can’t find this on the account page see screenshot)

DNSSEC never was the first step.

Pause Cloudflare completed (first step)

Good, now make sure that your site loads fine on HTTPS. You will need to talk to your host about that.

see screenshot (safari) left is says in Dutch , not secure but the redirect works
what do i have to ask the host?
I have already called them three times about this


You are loading your site on HTTP.


You need to make sure that loads fine and that’s what you need to discuss with your host.

1 Like

why did I create a Cloudflare account for this if I had to ‘search’ / change my host?

This on recommendations from pixels…