Battling with DKIM records Text or Cname?

I’m really battling with DKIM records - I’ now spent more than a week trying how to get this, my host says a txt record and gave me the entry but Cloudflare says add it as a CNAME record - its says the maximum target length cannot be longer than 63 characters - I’m just so tired of clutching at straws doing things I have no idea of what I’m doing - I can never seem to find any clear instruction on this.

this is what I have received from my host.


Type: TXT

Value: v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAndr7fFoKpNRS4aH+YpbGmVS4G6ibvCvUOtubydk4kLd7zeiPb58RjIvuxuXWvxBinrJrXI7leH7SH+T24AKeq6ZjE4IIBRUzeiwrJX7jM7wctYuu6+PMT73TaoUkor9LLD15PtOJJnbPfWypJ/u1qsGQtLDA+qXx5k/z7UgRykjT99gVvD82z81l7RQpzmTkeCmFdwU4t18qZEXKVrFDGwbGFJMnY+lqIy79+AD6jJetoY9d22BVx1QzzvE+2mS9zutP8Mwnc7jzlt42ai2+FRm/bRTdrILX8XNlJEq5lE85gARvXXlbzF78eXM7FydZZNHmLOuK3DF4GS3b2n3ULQIDAQAB;

I really would appreciate some help please.

Where does Cloudflare say to add it as a CNAME?

It should be a TXT record and what you have looks fine. The easiest way is to use the DKIM helper in the Dashboard (in the domain, under DNS, choose Settings, then click Email Security, then in the DKIM section, click Add Record; the link I provided should get you there) and paste in the selector (in your case, default) and the content as your host gave you.


I read it here on the community forum that the dkim must be a CNAME record though my host says TXT record. I tested all the records at and according to the site all the records are fine, my email is setup correctly and yet I still cannot send or receive mail - and I should add that everything was working until I tried the email routing stopped it and removed all the entries, now putting them back again and nothing works

It sounds like you’re saying you enabled Cloudflare’s Email Routing, then shut it back off? If that’s the case, it probably blew away your previous mail configuration (MX record) and you will need to add that back in the way it was before you enabled Email Routing. (Do not just re-add the records that Email Routing generated for you.)

I have done that and also checked all the records with and according to this web site they all correct. I’m still cannot send or received email. Even my host is now stumped and there is nothing else they can do.

Assuming the domain in your initial post, your MX mail server ( is answering connections and I can connect to it just fine on port 25. I see no Cloudflare-related reason why your email shouldn’t work.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.